Peercoin Proof of Stake Minting Setup Guide


#1

Perhaps this forum needs to make a list of other PPC references and then develop a few good summaries of its own.

I’m still learning but here’s where I’m at:

There is a guide: “Peercoin Proof of Stake Minting Setup Guide” but that’s for Microsoft Windows. The Linux version looks to simply be a matter of adding the Server=1 to the .conf file having the -qt with a locked wallet and running a terminal in parrallel with the commandline:
ppcoind walletpassphrase YourWalletPasswordHere 9999999 true

-qt then shows the wallet is locked but unlocked for Stake Minting.

I haven’t read in depth but it seems then that stake is relative to how long that runs… perhaps after a month I’ll see a small return but more interestingly that I’ll be then contributing blocks - which is when I’m expecting my deamon becomes useful. That does seem to suggest perhaps very few Proof of Stake deamons are likely to be running currently and then PPC will only work as Proof of Stake and not depend on Proof of Work if there is a large user base and a fair number of coins staked like this. Perhaps then that is understood and perhaps that’s why the coin limit is higher than other coins… good chance I’m wrong about this though.


#2

Thank you for the intro. I found this to work:

in the /home//.ppcoin
create file ppcoin.conf -------unlike in Windows, no capital letters!

with content:

server=1 rpcuser=randomname rpcpassword=randompassword
save and change access conditions according to safety procedures.

Do encrypt your wallet if not already done so. Observe precautions, write down the password, store in a safe location. (Pin it up on your monitor with red letters “DO NOT REMOVE, THIS IS THE SECRET PASSWORD TO ALL MY POSSESSIONS IN PPCOIN WALLET”, or use your own method if you have any better.) ((I will not go into detail here now.)

By encrypting your wallet, the ppcoin-qt will quit.

Now, notice, the “server=1” that you have written in the ppcoin.conf means that the ppcoin-qt will act as a server the next time you run it.

This server feature can be used by the ppcoind. Go to the location where your ppcoin-qt and ppcoind are located (where you installed, compiled or unpacked them). If you are running an AMD64 system, use those in folder named “64”.
now, run in that place command

./ppcoind walletpassphrase <secretpasswordtoyourwallet> 9999999 true
If everything’s alright, you should not notice anything, because the daemon runs in background, trying to do the minting work. I’m not yet sure if a supply of Wrigley’s Mint Fresh or similar will be needed to replenish the minting ability, in any way, let the father time do his job. I’ve been told that more than 30 day old coins are needed.

Possible errors:
“error: you must set rpcpassword” - your ppcoin.conf was not read correctly, is it named ppcoin.conf?
“error: couldn’t connect to server” - your wallet - ppcoin-qt must be up and running.

Why are seven nines needed in the ppcoind argument? Don’t ask me! But I have a feeling that ChinaCoin uses 88888888.

Please, think of the children. Feed the troll. Otherwise the troll will come out of the closet and make them scream in the night!


#3

The seven 9’s are just a very long time limit before the password locks again. If you send coins from the commandline, you unlock the wallet long enough that you can action the sendto in the next command while it’s unlocked.


#4

With a fair amount of coins in stake, does it make sense to increase the number of network connections of ppcoin-qt?

I tested it with “maxconnections=16” in the ppcoin.conf file, but my wallet sticks to 8 active connections.

Does it matter, any proposal?


#5

With port forwarding I saw the connections jump in the same way as for other coins but then they fell back to 8. I’m still waiting for PoS to kick in, so I don’t know if active PoS might encourage more connections.

I don’t know, if there is substantial value in having more than 8 connections, if you’re not a miner… but I’m assuming it can only be useful.


#6

The 8 active connections are outgoing only, isn’t it? So port forwarding (for incoming connections) does not make sense with PoS, doesn’t it?

I wish to secure the PPC network with my stake. Is it necessary for this to enable incoming connections with port forwarding?

My 30 days have been completed in May, and since around one week I generate stake blocks (without port forwarding).


#7

Is it necessary to enable incoming connections for making my node add more securing functionality?

I have 8 active outgoing connections. I talk about PoS only, I’m not interested in PoW.


#8

Am I right that if I don’t encrypt my wallet and just set daemon=1 in ppcoin.conf, I should be able to run ppcoin-qt once in a while and see POS generated by my PPCs (after 30 days) according to how much coin age my coins have accumulated? Thanks


#9

Yes, but yet better is to encrypt your wallet. For details see
https://bitcointalk.org/index.php?topic=187714.0


#10

Thanks. The risk of my forgetting the password after a year, and ruining all the fun, is way, way higher than someone’s breaking in my computer and stealing a few dollars’ worth of PPCs! :smiley:

ed:typo


#11

I know what you mean. As an administrator I had to evolve a rather sophisticated three tier system that works very fine to me:

  1. fragments (3 to 5 chracters in length) of pronouncable passwords on a paper (distributed)
  2. for every login a compound abbreviation of every fragment on my mobile (backuped and distributed)
  3. systematic and easy modification of every fragment in my head (not backed up)

So I nowhere have the same password. And the higher the possible loss, the more fragments in my password.


#12

Here is another description in this forum, with some description of the proof-of-stake functionality:
http://www.ppcointalk.org/index.php?topic=6.0;topicseen


#13

Thanks for the pointer


#14

Hey guys…

I followed the instructions, and when I run as a server, I get the following:

[font=courier]~/bin$ ./ppcoind <passfromppcoin.conf> 9999999 true
error: couldn’t connect to server[/font]

That was remedied by actually launching ppcoin-qt… :slight_smile: But the real issue is next:

[font=courier]~/bin$ ./ppcoind <passfromppcoin.conf> 9999999 true
error: {“code”:-32601,“message”:“Method not found”}[/font]

Searched around a bit and haven’t found mention of this one…


#15

ppcoind walletpassphrase YourWalletPasswordHere 9999999 true

walletpassphrase is the method. Only replace in that what is your password.

The only change I’ve had to make is recognising that the # at the beginning of the ppcoin.conf line for reservebalance does matter.

I am still confused by the stake field. I’ve restarted the server recently and it seems everything is in the balance of getinfo. I wonder the that either all of the coins are understood as being older that one month or that the clock was reset but I don’t understand why if the transactions know the time the coins were sourced that it would do that… prehaps the local clock is not trusted and there is no clock it can trust.

Last time I did get some coins created from stake but the balance I have was an odd split into stake and balance, which I couldn’t make sense of… so I’m trying again to wait a month+ and see if the change to reservebalance field in the config does affect what happens in a clear way.

Obviously, we’re all using beta software but it does seem there is some work needed on usability and clarity still.


#16

please don’t supply your passphrase on the command line! Your terminal will remember the command for a while.

I use a little bash script that slightly improves this security hole:

#!/bin/bash
echo "make sure you've started ppcoin-qt first."
read -s -p "Enter ppcoin wallet passphrase  : " passphrase
echo "starting ppcoind with stake mining enabled"
ppcoind walletpassphrase $passphrase 9999999 true

and make sure you’ve created the ppcoin.conf file as described earlier.

enjoy stake minting


#17

Sorry to bring up an old post but I don’t suppose anyone knows how to set up PoS on a mac do they? I’ve got the conf file all set up but I’m getting “minting suspended due to locked wallet” just can’t workout how to get it to work. I tried running the app from the command line with the parameters mentioned here but that didn’t happen either :frowning:

Any ideas would be much appreciated :slight_smile:


#18

Sorted it for anyone else having the same problem here’s what to do:

First go here http://www.ppcointalk.org/index.php?topic=6.0 and download both the QT wallet and ppcoind. Install PPcoin-qt and save ppcoind somewhere i just put it in my Documents folder for now but it doesn’t matter. Then you need to run ppcoin-qt after that navigate to where you put ppcoind in terminal so for me it was:

cd /Users/yourusernamehere/Documents

Then run:

./ppcoind walletpassphrase 9999999 true

that should have you working :slight_smile: - hope this helps someone


#19

Thanks, this is helpful. My main wallet is on Linux, but I have another one on Mac and will try it.


#20

I am still not sure how to mint POS if the wallet is not encrypted. Do I just leave the qt wallet on to mint POS? I have setup the ppcoin.conf file. When I try “ppcoind walletpassphrase %variable% 9999999 true” command I got the error message

error: {"code":-15,"message":"Error: running with an unencrypted wallet, but wal
letpassphrase was called."}