Peercoin Proof of Stake Minting Setup Guide


#21

Could someone please explain to me exactly how to achieve this on linux please? i just don’t quite follow what’s being said here. Thanks.


#22

I just leave my wallet open. It’s got the locked symbol bottom right but as long as i’m running ppcoind with the walletpassphrase it doesn’t give me an error about minting. I’d imagine the setup on linux is very similar to on OSX though I’ve not tried on linux.

I got a random payment of 0.013 so I assumed that was the minting doing it’s job?


#23

When i run this in terminal :

ppcoind walletpassphrase xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 9999999 true

I get this error

ppcoind: command not found.

This is driving me mad. Can someone please help me work this out on linux? PLEASE?!


#24

make sure you’ve navigated to the folder ppcoind is located in then I think you’ll have to run it like

./ppcoind walletpassphrase ************ 9999999 true

don’t forget the ./ or it won’t work.

Try that :slight_smile:


#25

[quote=“mehmehspazumweh, post:23, topic:93”]When i run this in terminal :

ppcoind walletpassphrase xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 9999999 true

I get this error

ppcoind: command not found.

This is driving me mad. Can someone please help me work this out on linux? PLEASE?![/quote]

I don’t run it on linux. But on windows ppcoind is in the daemon directory. make sure to cd daemon first.


#26

[quote=“mhps, post:25, topic:93”][quote=“mehmehspazumweh, post:23, topic:93”]When i run this in terminal :

ppcoind walletpassphrase xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 9999999 true

I get this error

ppcoind: command not found.

This is driving me mad. Can someone please help me work this out on linux? PLEASE?![/quote]

I don’t run it on linux. But on windows ppcoind is in the daemon directory. make sure to cd daemon first.[/quote]

yeah make sure u in the src directory if you have built the code from source… also if you are in the correct directory try…

./ppcoind walletpassphrase xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 99999999 true

FuzzyBear


#27

sigh I have get answer to my question from discussion about a another coin (Philosopherstone) https://bitcointalk.org/index.php?topic=263744.200
The answer to my question is yes.


#28

First off, let me say that I think Proof of Stake is a great idea and it really sets PPCoin apart from the pack.

I’ve been trying to get setup for minting on Debian and I’ve had some issues but I think I may have finally figured it out. However, I have a question. I currently mine on a Raspberry Pi…does ppcoind need to be running on the same machine that the miner is running on?

Thank you.


#29

Is there any indication of how many coins are mature enough to mint with POS?

For example, I am sure I have had coins on this server that have been available for more than 520 blocks + 30 days.

[tt]$ ppcoind getinfo
{
“version” : “v0.3.0ppc-26-g154b52a-dirty-beta”,
“protocolversion” : 60003,
“walletversion” : 60000,
“balance” : 185.12451500,
“newmint” : 0.00000000,
“stake” : 0.00000000,

[/tt]

Some kind of clue what to look for in the log file to verify that things are working would be nice.


#30

Couldn’t be too hard to work something into a future PPC wallet that shows the amount of coins ready for stake minting. For example, in pseudocode, it’d be like (if CoinAge>=30days, Mintable==TRUE, sum CoinAgeMintable, sum MintableTotal, else Mintable==FALSE, TotalMintableCoinAge = Mintable * CoinageMintable) or something to that effect.


#31

I’ve been trying to get setup for minting on Debian and I’ve had some issues but I think I may have finally figured it out. However, I have a question. I currently mine on a Raspberry Pi…does ppcoind need to be running on the same machine that the miner is running on?

Thank you.


#32

Sorry to pester but I’ve been trying to figure this out and I simply cannot for the life of me find clear directions on setting up / installing ppcoind (for POS minting) on Ubuntu 12.04 (or any version of linux


#33

Look here in this topic: http://www.ppcointalk.org/index.php?topic=186.msg572#msg572

It works rather straightforward for me, working also on Ubuntu 12.04. What’s the problem/symptoms exactly?


#34

[quote=“brenzi, post:16, topic:93”]please don’t supply your passphrase on the command line! Your terminal will remember the command for a while.

I use a little bash script that slightly improves this security hole:

#!/bin/bash
echo "make sure you've started ppcoin-qt first."
read -s -p "Enter ppcoin wallet passphrase  : " passphrase
echo "starting ppcoind with stake mining enabled"
ppcoind walletpassphrase $passphrase 9999999 true

and make sure you’ve created the ppcoin.conf file as described earlier.

enjoy stake minting[/quote]
works like a charm :wink: thx!


#35

Well no matter how I configure it, I get the following error:

error: {“code”:-32601,“message”:“Method not found”}

I’m thinking maybe I have to re-compile the client with a certain library that isn’t present on my machine.

also when you say:

walletpassphrase passphrase

is walletpassphrase the password in ppcoin.conf and passphrase is the passphrase you made when encrypting the wallet?

Thank you.


#36

[quote=“pajarillo, post:34, topic:93”][quote=“brenzi, post:16, topic:93”]please don’t supply your passphrase on the command line! Your terminal will remember the command for a while.

I use a little bash script that slightly improves this security hole:

#!/bin/bash
echo "make sure you've started ppcoin-qt first."
read -s -p "Enter ppcoin wallet passphrase  : " passphrase
echo "starting ppcoind with stake mining enabled"
ppcoind walletpassphrase $passphrase 9999999 true

and make sure you’ve created the ppcoin.conf file as described earlier.

enjoy stake minting[/quote]
works like a charm :wink: thx![/quote]Is this for Windows or for Linux? Bare with me, I’m not the best with computers. But I am all for making things more secure. Is there a way to make it more secure in windows?


#37

[quote=“estebanrules, post:35, topic:93”]Well no matter how I configure it, I get the following error:

error: {“code”:-32601,“message”:“Method not found”}

I’m thinking maybe I have to re-compile the client with a certain library that isn’t present on my machine.

also when you say:

walletpassphrase passphrase

is walletpassphrase the password in ppcoin.conf and passphrase is the passphrase you made when encrypting the wallet?

Thank you.[/quote]

“walletpassphrase” is the RPC command and “passphrase” the wallet encrypting password.
so something like:

ppcoind walletpassphrase YourEncryptionPassWordHere 9999999 true

unlocks the wallet for minting for a total of 9999999 seconds.
You can verify success e.g. by checking with

ppcoind getinfo

the end of the output should look like

    "unlocked_until" : 1392536620,
    "errors" : ""

#38

[quote=“Alertness, post:36, topic:93”][…]

#!/bin/bash
echo "make sure you've started ppcoin-qt first."
read -s -p "Enter ppcoin wallet passphrase  : " passphrase
echo "starting ppcoind with stake mining enabled"
ppcoind walletpassphrase $passphrase 9999999 true

[…]
Is this for Windows or for Linux? Bare with me, I’m not the best with computers. But I am all for making things more secure. Is there a way to make it more secure in windows?[/quote]

This is a script for Linux, Unix and whatever system running a bash. If you like to run a script like this on a Windows machine, you can try to get familiar with MinGW :wink:

…I might be wrong and please correct me if so, but…
If you unlock your wallet in Windows using the daemon (ppcoind.exe) within a command prompt, there is no big risk if you close the command prompt after you have unlocked the wallet for stake minting. There is no history for a command prompt that stays after you have closed the prompt - unlike Linux that might be configured saving a command histroy (e.g. .bash_history or similar).


#39

Need help on a Mac. This is what I’ve done so far:

  1. Have PPcoin-Qt installed and encrypted. I have ppcoind in my documents folder.

  2. I open PPcoin-Qt so it’s running then I open up terminal and navigate to: cd /Users/username/Documents

  3. terminal shows me that I’m in: Documents username$

  4. then I try running: ./ppcoind walletpassphrase ************* 9999999 true
    and I get the following error: -bash: ./ppcoind: Operation not permitted

Can anyone help?


#40

I am having the same “Operation not permitted” issue with ppcoind on my Mac. I’ve been successfully using curl with the PPcoin-Qt JSON RPC interface instead.

For example, with the following in your ~/Library/Application\ Support/PPCoin/ppcoin.conf

#Server mode allows Qt to accept JSON-RPC commands
server=1

# You must set rpcuser and rpcpassword to secure the JSON-RPC api
rpcuser=rpcuser
rpcpassword=rpcpassword
rpcport=9082

Start PPcoin-QT like normal, and run the following curl command in your terminal (replacing <wallet_password> with the proper values):

curl --user rpcuser:rpcpassword --data-binary '{"jsonrpc": "1.0", "id":"curltest", "method": "walletpassphrase", "params": ["<wallet_password>",9999999,true] }' -H 'content-type: text/plain;' http://127.0.0.1:9082

If it was successful you’ll see the following output, and the “minting suspended” message will clear after a couple of minutes.

{"result":null,"error":null,"id":"curltest"}

Keep in mind that this will be saved in your terminal history (as mentioned previously). For anything more than testing you should use something like the script mentioned earlier in this thread, with the ppcoind call replaced with the curl call above.