(Tutorial) Configuring Peercoin Proof-of-Stake Minting on OS X

#61

[quote=“tomish, post:53, topic:939”]The EOF error is caused by the " character not copying properly i think.
To remove the error find all instances of " in your start.sh file and replace them by typing a " char manually :slight_smile:

(using nano as explained above)[/quote]
This fix worked for me. Thanks!

Am I ready to start using PPC?

#62

@Sethrips, I found success with the Permission Denied issue by following both of Ben’s previous suggestions of:

  1. recopying to correct for " issues (see change in Step 6 of his original posts of this thread)
  2. making the sudo change (see Ben’s ‘Reply #21 on: November 29, 2013, 03:48:14 am’ in this thread)

I continued to have Permission Denied appear before doing both corrections. I recommend using those.

#63

Okay I’ve gotten all the way through it but I’m getting this error at the very end:

Ezekiels-MacBook-Pro:PPCoin kazem666$ ./start.sh
Please ensure that you have started PPCoin-Qt before entering your passphrase.
Enter Peercoin wallet passphrase: Starting ppcoind with stake minting enabled
error: value is type bool, expected int

It says it’s enabled but the little lock is still locked shut.

#64

@kazem:

I worked through a similar issue with sethrips today, and what it turned out to be was that his passphrase had at least one space and a “*” in it. At this time, it appears that special characters and spaces are causing ppcoind to choke. I’m investigating whether this is an issue with the start.sh script, or if it’s something else.

In the meanwhile, if you would test to see if removing any spaces or special characters fixes the problem, I would appreciate it.

If you don’t have either of those in your password, let me know, and I’ll keep investigating. Thanks!

#65

Ben,

I don’t have any special characters or spaces in my passphrase. I changed my passphrase to something with all letters just for a quick test and when I ran the start.sh script again I got the same error.

I’m running off Mavericks if that means anything.

Thanks!

#66

What happens if, instead of running start.sh, you use call ./ppcoind directly?

$ ./ppcoind walletpassphrase YourWalletPassphraseGoesHere 9999999 true

Do you get the same error?

#67

Ben, clearly I have no idea what’s going on. When I entered $ ./ppcoind walletpassphrase YourWalletPassphraseGoesHere 9999999 true
It gave me this: error: {“code”:-17,“message”:“Error: Wallet is already unlocked, use walletlock first if need to change unlock settings.”}
I looked and sure as shit, it was unlocked. Not sure how or when it happened but I’m glad it did. Thanks for all your help.

#68

:slight_smile: Glad to be of, um, help in that case :slight_smile:

I’m working on an improved start script, with better error handling, so as soon as I’ve had a chance to run it through preliminary tests on my own system, I’ll release it for wider review.

#69

I am unable to download ppcoind.zip from Mega on OSX. The message I keep receiving is: Temporary error, retrying.

Any suggestions?

#70

I just tried, but didn’t run into any problems.

I just downloaded ppcoind.zip and made it available. I can promise it’s the same one that you tried to DL from the Mega site, and the SHA should match if you want to validate that it hasn’t been tampered with.

ppcoind.zip

#71

Thanks for the excellent tutorial! ;D

In step 7 I get a ‘type mismatch’ error message. I will try the suggestions to change PPcoinQT password since my current password contains spaces.

$ ./start.sh Please ensure that you have started PPCoin-Qt before entering your passphrase. Enter Peercoin wallet passphrase: Starting ppcoind with stake minting enabled error: type mismatch

#72

Sure enough. It was the presence of spaces in the password that caused the ‘type mismatch’ error. If I remove the spaces I can start minting succesfully…

I also found a fix for the start.sh script, the variable $passphrase just need to be passed in quotes.

#!/bin/bash echo "Please ensure that you have started PPCoin-Qt before entering your passphrase." read -s -p "Enter Peercoin wallet passphrase: " passphrase echo "Starting ppcoind with stake minting enabled" ./ppcoind walletpassphrase "$passphrase" 9999999 true

Donation bin: PPHL6KebUkjMzFzTN2sq3xVrVfbp7bLUYe

#73

Good catch, fatpaul, I’ll fix that right now.

#74

Like others, I’m also receiving the following message after inputting my wallet password:

Enter Peercoin wallet passphrase: Starting ppcoind with stake minting enabled error: incorrect rpcuser or rpcpassword (authorization failed)

I get the same message if I run it from the start.sh or using ppcoind. Thoughts?

#75

Can you confirm that in your [font=courier]ppcoin.conf[/font] file you have both rpcuser and rpcpassword filled out, they don’t start or end with “<”, “>” and neither have been commented out (with a leading “#”)?

If all of those conditions look good, the next reason I’ve seen that happen is because you’re entering a passphrase that doesn’t match your wallet passphrase (at the prompt, not for the rpcpassword value)

#76

Yes, the ppcoin.conf looks good.
I’ve also reset my wallet passphrase to ensure it’s correct with no success.
Not sure if this might help:

drwxr-xr-x 21 userName staff 714 Dec 6 22:11 . drwx------+ 81 userName staff 2754 Nov 30 08:24 .. -rw-r--r--@ 1 userName staff 6148 Dec 6 20:20 .DS_Store -rw------- 1 userName staff 0 Nov 10 18:55 .lock -rw------- 1 userName staff 24576 Dec 5 22:44 __db.001 -rw------- 1 userName staff 999424 Dec 6 22:14 __db.002 -rw------- 1 userName staff 32776192 Dec 6 22:14 __db.003 -rw------- 1 userName staff 1179648 Dec 6 22:04 __db.004 -rw------- 1 userName staff 4653056 Dec 6 22:14 __db.005 -rw------- 1 userName staff 40960 Dec 6 18:59 __db.006 -rw------- 1 userName staff 745472 Dec 6 22:14 addr.dat -rw------- 15 userName staff 123368241 Dec 6 22:05 blk0001.dat -rw------- 12 userName staff 81403904 Dec 6 22:05 blkindex.dat drwxr-xr-x 2 userName staff 68 Dec 6 22:11 daemon drwx------ 4 userName staff 136 Dec 6 22:08 database -rw------- 1 userName staff 62 Nov 17 22:56 db.log -rw------- 1 userName staff 4776913 Dec 6 22:15 debug.log -rw-r--r--@ 1 userName staff 2420 Dec 6 22:02 ppcoin.conf -rwxr-xr-x@ 1 userName staff 5668888 Apr 29 2013 ppcoind -rwxrwxr-x 1 userName staff 262 Dec 6 20:22 start.sh -rw------- 1 userName staff 73728 Dec 6 22:05 wallet.dat

One thing that’s interesting is that I ran ./ppcoind getinfo and I get the same error: incorrect rpcuser or rpcpassword (authorization failed) message.

#77

Can you please post the contents of your [font=courier]ppcoin.conf[/font] file?

#78
# ppcoin.conf configuration file. Lines beginning with # are comments. # Network-related settings:

Run on the test network instead of the real peercoin network.

#testnet=0

Connect via a socks4 proxy - default none

#proxy=127.0.0.1:9050

Accepting incoming connections

listen=1

UPnP

#upnp=1

Use as many addnode= settings as you like to connect to specific peers

addnode=66.90.146.146
addnode=91.156.102.128
addnode=110.174.124.20
addnode=67.14.164.114
addnode=37.209.40.22
addnode=50.71.216.165
addnode=109.108.236.208
addnode=173.28.37.150
addnode=68.102.86.156
addnode=213.251.187.24
addnodd=188.134.122.31
addnode=72.38.179.122

… or use as many connect= settings as you like to connect ONLY

to specific peers:

#connect=69.164.218.197
#connect=10.0.0.1:8333

Maximum number of inbound+outbound connections.

maxconnections=64

JSON-RPC options (for controlling a running Bitcoin/bitcoind process)

server=1 tells PPcoin-QT to accept JSON-RPC commands.

server=1

You must set rpcuser and rpcpassword to secure the JSON-RPC api

rpcuser=nskjnasdknfksnfkajnsdk
rpcpassword=jksnagkjfndkfjgankn34

How many seconds peercoin will wait for a complete RPC HTTP request.

after the HTTP connection is established.

rpctimeout=30

By default, only RPC connections from localhost are allowed. Specify

as many rpcallowip= settings as you like to allow connections from

other hosts (and you may use * as a wildcard character):

rpcallowip=127.0.0.1
rpcallowip=192.168.1.*
rpcallowip=10.0.0.*

Listen for RPC connections on this TCP port:

rpcport=9902

You can use ppcoind to send commands to ppcoind

running on another host using this option:

#rpcconnect=

Use Secure Sockets Layer (also known as TLS or HTTPS) to communicate with ppcoind

#rpcssl=1

OpenSSL settings used when rpcssl=1

#rpcsslciphers=TLSv1+HIGH:!SSLv2:!aNULL:!eNULL:!AH:!3DES:@STRENGTH
#rpcsslcertificatechainfile=server.cert
#rpcsslprivatekeyfile=server.pem

Pre-generate this many public/private key pairs, so wallet backups will be valid for

both prior transactions and several dozen future transactions.

#keypool=100

#The reserve balance field is the minimum amount of coins you want to have available and NOT put up as stake.
#The reason for this is that if you are generating proof of stake you cannot spend those coins for 520 blocks.
#reservebalance=10000

#79

I know this much be a very stupid question, but for step six, using the following:

#!/bin/bash
echo “Please ensure that you have started PPCoin-Qt before entering your passphrase.”
read -s -p "Enter Peercoin wallet passphrase: " passphrase
echo “Starting ppcoind with stake minting enabled”
./ppcoind walletpassphrase “$passphrase” 9999999 true

What needs to be changed before WriteOut? Does any text need to be deleted and do I
put in my passphrase where it says "Enter Peercoin wallet passphrase: " or “$passphrase”?

#80

Thanks so much!!! Worked through it and its working!!!