(Tutorial) Configuring Peercoin Proof-of-Stake Minting on OS X

#41

on step 4, when I enter the command “mv ppcoind ~/Library/Application\ Support/PPCoin/” i get the error message “no such file or directory.” I assume that the folder where ppcoind is suppoed to be going isn’t there. how do i fix this? i already have the qt wallet encrypted and syncronized.

#42

Hi again, I changed my wallet pass to my permanent pass and ran again the ./ppcoind walletpassphrase myPass 9999999 true

It’s working fine now. I don’t know what I did wrong before, but it’s working now.

I used cat /dev/null > ~/.bash_history to flush the history

It’s my assumption now that as soon as I receive some coins my PPcoin-Qt will automatically being minting at 1%/yr? If you can point me to a tutorial that explains how the minting really works in terms of hardware and speed, that will be great. Do I need fast graphic card to reach that top 1%/yr? what if I’m minting PPcoin, Litecoin, Novacoin, etc all at the same time in the same Mac? I know I went off-topic so please feel free to refer me to another thread.

Thanks again!!!
Alejandro

#43

@Alejandro,

Maybe, but if I look in mine, I’m noticing that there’s nothing actually in it. You can try to see if that makes a difference however:

$ cd ~/Library/Application\ Support/PPCoin/
$ mkdir -m 755 daemon

That moves you into the PPCoin application directory, creates a subdirectory called ‘daemon’ and configures the permissions on the folder to match [font=courier]drwxr-xr-x[/font]. You may need to use ‘sudo mkdir -m 755 daemon’ to do that, depending on how your system is configured, but on mine, I didn’t need to.

sethrips, I have a feeling that you’re seeing that because you already moved the ppcoind file to the directory. That’s what I see if I use Step 4 to move a test file from [font=courier]~/Downloads[/font] to [font=courier]~/Library/Application\ Support/PPCoin/[/font] and then mistakenly run the same command again.

The first thing you can check is to see if the ppcoind file is still in your Downloads directory:

$ cd ~/Downloads/
$ ls ppcoind

If it is there, you’ll see “ppcoind” displayed, if it isn’t, the console will report back with this message: ls: ppcoind: No such file or directory. If the file isn’t in the Downloads folder, let’s check to see if it had already been moved to the PPCoin application directory.

First set your context to the PPCoin application directory and then list the files, do you see [font=courier]ppcoind[/font] there?

$ cd ~/Library/Application\ Support/PPCoin/
$ ls ppcoind

Please let me know what you find.

#44

Ben thanks for all your help on this.

I ran it just as you instructed and now I get this: error: incorrect rpcuser or rpcpassword (authorization failed)

I changed my passphrase in my wallet to something simple for a test and tried it again with the same result.

#45

I’m glad it is working for you now, Alejandro :slight_smile:

Regarding how minting really works, I’m currently working with a couple members of the community and Sunny King to come up with a simple explanation for how Proof-of-Stake works, what it means for the coins in your wallet and what you need to know to maximize your chances to solve stake blocks.

Rest-assured, Proof-of-Stake is intended to be a very energy-efficient replacement for Proof-of-Work mining, and as such, it is my understanding that a “normal” computer’s processor is more than sufficient attempt to solve blocks.

As soon as I have a simplified description, I’ll create a new topic and post the information there (and on the Peercoin wiki). In the meantime, you can read the in-progress topics that we have going discussing the mechanics of PoS and what it all means. These are by no means linear in nature, and they jump around a lot to different aspects of PoS, but if you don’t mind the lack of organization or completeness, it’s a good starting point.

PoS - How does it really work? Long and maybe confusing thread incoming
Understanding the mechanics and day-to-day implication of Proof-of-Stake

#46

[quote=“kazem666, post:44, topic:939”]Ben thanks for all your help on this.

I ran it just as you instructed and now I get this: error: incorrect rpcuser or rpcpassword (authorization failed)

I changed my passphrase in my wallet to something simple for a test and tried it again with the same result.[/quote]

I need to jump offline for about an hour, Kazem, but as soon as I’m able to get back, I’ll walk through the instructions on a fresh machine and see if there’s a broken step that may be causing that issue you are seeing.

In the meanwhile, would you please take a couple minutes to go back through your [font=courier]ppcoin.conf [/font]file and make sure that there aren’t any lines mistakenly commented out with a “#” in front of them in your file, vs. what I show in the steps?

Thanks!

#47

Ben, I still get the same message when I do both commands. When I go into my downloads folder, the file is there. But when I search for it like you say to do in terminal, I get “no such file in directory.” I simply do not think that the “ppcoin directory” exists on my computer, for some reason. Thanks. -Seth

#48

Ben I just went through the whole process from the top again. when I got to step 5 the ppcoin.conf file. I copied and pasted it from your instructions and looking it over everything matches up exactly except the “rpcuser” and “rpcpassword” which I changed. I still am getting this error when I try and run: ./start.sh from step 7

Ezekiels-MacBook-Pro:PPCoin kazem666$ ./start.sh
./start.sh: line 2: unexpected EOF while looking for matching `’’
./start.sh: line 6: syntax error: unexpected end of file

and when I run the following: ./ppcoind walletpassphrase 9999999 true with my wallets passphrase I still get:

Ezekiels-MacBook-Pro:PPCoin kazem666$ ./ppcoind walletpassphrase 9999999 true
-bash: mypassphrase: No such file or directory

Here is my list directory. If it’s of any use to you.
Ezekiels-MacBook-Pro:PPCoin kazem666$ ls
__db.001 __db.004 addr.dat daemon debug.log start.sh
__db.002 __db.005 blk0001.dat database ppcoin.conf wallet.dat
__db.003 __db.006 blkindex.dat db.log ppcoind

#49

ive made it much farther…all the way until the “moment of truth”…where i get the message “permission denied.” dammit. please help. tons of karma coming your way.

#50

In that case, let’s move it using the OS X graphic interface. This is a tiny bit more complex, because we’re going to be moving the file into a “hidden” folder (~/Library/), but I’ll walk you through it.

Step 1: Let OS X know that you want to see hidden files

This step will require you to use Terminal, but we won’t need to use it again for a while after this step. Open up the Terminal app, and at the prompt, enter these commands (and if you get lost at all, you can find a great primer for doing this at OSXDaily.com). Remember, you don’t need to include the “$” when you copy the line, that’s just to indicate where the prompt is.

For OS X 10.9 (Mavericks)

$ defaults write com.apple.finder AppleShowAllFiles TRUE

For OS X 10.8 (Mountain Lion), 10.7 (Snow Leopard) and 10.6 (Leopard)

$ defaults write com.apple.Finder AppleShowAllFiles TRUE

After you enter that command, you’ll need to restart the Finder, so use this (same for all OS X 10.x versions):

$ killall Finder

The Finder will quickly restart, and when it comes back, you’ll be able to see hidden files in the finder windows. They show up as dimmed files. It will stay this way until you reverse the change; instructions are included in the link I provided above, if you want to revert it once we’ve finished moving [font=courier]ppcoind[/font].

Step 2: Copy ‘ppcoind’ from the location that it currently lives and move it to the PPCoin directory

From the Finder window (where you select files and start up applications), go to the directory that [font=courier]ppcoind[/font] currently is located, select it and use COMMAND+C to copy it to the clipboard.

Next, in the Finder, navigate to the root of your user account. This is the directory that contains the “Downloads”, “Pictures”, “Music”, “Applications”, etc. folders where you store your files and other things. With hidden files now being shown, you should see a couple of dimmed folders. Locate the “Library” folder and then right-click, select “Open” (sometimes you can’t double-click hidden files to open them)

Once open, locate the “Application Support” folder and drill down into it. Inside you should find a folder called “PPCoin”.

This is the folder that you want to open up, and then paste in the [font=courier]ppcoind[/font] file you had copied earlier.

Step 3: Back to the command line

After you’ve copied the file into the directory, you can go back to the tutorial step you were on and run the commands in the Terminal.

Hope that helps, let me know if this gets you farther along.

#51

Thanks so much for doing this!

I have gotten as far as the EOF error that other people were getting. I was able to unlock my wallet using [tt]./ppcoind walletpassphrase 9999999 true[/tt], but I’m not sure what my next steps are. Am I set, or should I be waiting for the error I mentioned to be resolved?

I am new to cryptocurrency and really have no idea what I’m doing, so this tutorial is a godsend.

#52

@Ben
this guide is really good and useful thanks… have linked to this thread from the proof-of-stake video i did… hopefully it should help some people out…

#53

The EOF error is caused by the " character not copying properly i think.
To remove the error find all instances of " in your start.sh file and replace them by typing a " char manually :slight_smile:

(using nano as explained above)

#54

/facesmack

OF COURSE! It’s a transcription error from the copy/paste of the code in when it was encoded by the forum.

@tomish, you’re a savior.


For those of you running into the EOF error, here’s a Gist that I created that you should be able to copy/paste into your start.sh script using Nano that won’t give you the problem. I took this opportunity to fix some of the wording in the script (non-function, just the text output), so it will look a little different than what you had before.

#55

@tomish great catch!

@ben thanks so much for all your hard work and patience with us noobs on this. I’m finally past that phase. :slight_smile: When I enter my password I get this: error: value is type bool, expected int I’m guessing it’s because I have currently have 0 ppc in my wallet. Still have 2 more days to wait before BTC-E will let me withdrawal them.

#56

Ben, thanks for all the help. In the end, I’m still getting the error message “permission denied.” You’ve been such a help dude. I would really appreciate it if you could help me through the end. Thanks. -Seth

#57

Sethrips, did you check the file permissions suggestions a few posts back? That seems to be the fix for the “permission denied” error.

#58

Sorry ben I’m not seeing that. I know I’m almost there! So close. I don’t know what I’m doing wrong.

#59

Give this a try:

Note: when you run a command using ‘sudo’, it will prompt you for your SYSTEM password (that you log in with) – it’s not asking for your Peercoin wallet passphrase.

#60

I’m now to the point where I can actually get it to ask me for my password after I enter “./start.sh” but when I enter it, I still get the message “no such file in directory”