[SUPPORT] beeeeer.org - tech support


#1

hi,

this will be the thread for:

[ul][li]tech support / questions[/li]
[li]build support[/li]
[li]problems (rejects / reconnects / server down / maintenance / pool crash / miner crash / etc. pp.)[/li][/ul]

regarding the “beeeeer.org” pool

  • xolokram

#2

[s]first

maintenance incoming!

pool will be down for a few minutes, i’m trying to fix the rejection bug!![/s]

rejection bug fixed
there’s still a small issue that produces some rejects. i’m already aware of this. fix will come soon.

  • xolokram

#3

[quote=“xolokram, post:1, topic:358”]hi,

this will be the thread for:

[ul][li]tech support[/li]
[li]build support[/li]
[li]problems (rejects / reconnects / server down / maintenance / pool crash / miner crash / etc. pp.)[/li][/ul]

with the beeeeer.org pool

[more info coming soon]

  • xolokram[/quote]

maybe it’s a good idea to link to this thread in the pool announcement (http://www.ppcointalk.org/index.php?topic=485.0)


#4

yeah, you’re right. fixed

  • xolokram

#5

Does beeeeer.org still accept getwork connections? I am asking because the reaper gpu prime miner uses getwork to connect to the primecoind daemon so I would think I should be able to connect to beeeer.org with it as well but when I try to connect it states that curl throws an error 52 which means it got an empty or bad response… this might not be possible to do but I dont see any reason as of right now why it wont work unless getwork has been turned off.


#6

SOLVED
I have some trouble on a Windows machine (using http://www.mediafire.com/download/lw5v9ck4bho1dts/primeminer_v02_x86_and_x64.zip.zip)
I tried to connect to the pool using ssh forwarding (I let the miner connect to 127.0.0.1:1337 and forward that connection to 5.45.100.191:1337, here is the start script for the miner: primeminer_x32.exe -pooluser= -poolpassword=0 -poolip=127.0.0.1 -poolport=1337), but I get “system:10061” error messages.
Although I don’t know why this shouldn’t work, I see that it doesn’t.
Any ideas?
What does “system:10061” mean?

[edit]
I don’t know what went wrong in first place, but it works perfectly now that I restarted the ssh application. I have some more computing power to direct to the pool :wink:
[/edit]


#7

@Asphyxiated:
What command do you use to connect to beeeeer.org? Are you using port 9912 (‘getwork’) ?

  • xolokram

ps. thank you for using this thread


#8

I am trying to build the miner using commit 7b239dd on prescise1-Ubuntu. I get this error when g++ tries to compile alert.cpp : boost/algorithm/string/classification.cpp: No such files or directory


#9

@mhps:
install boost library

sudo apt-get install libboost-all-dev
or for everything:
sudo apt-get install git g++ libboost-all-dev libdb+±dev build-essential libgmp-dev libssl-dev

(it’s recommended to build the gmp library from scratch with the latest version)


#10

[quote=“Sy, post:226, topic:342”]Is it possible to “proxy” this pool via iptables?

I tried

iptables -t nat -A PREROUTING -p tcp --dport 1337 -j DNAT --to-destination 5.45.100.191:1337

but thats not working, i think its connecting but it keeps spamming a system #random number# message.[/quote]

I tried using a socks proxy combined with ssh forwarding. It turns out that this combination worked - at least for me. I did this on a Windows machine, but with Linux you should be able to do the same

ssh localhost -L 1337: beeeeer.org:1337 -N
and start the miner with 
primeminer -pooluser=yourAddressHere -poolpassword=0 -poolip=127.0.0.1 -poolport=1337 -genproclimit=whateverSuitsYourNeeds

I haven’t tried this, but maybe you want to? :wink:


#11

[quote=“masterOfDisaster, post:10, topic:358”][quote=“Sy, post:226, topic:342”]Is it possible to “proxy” this pool via iptables?

I tried

iptables -t nat -A PREROUTING -p tcp --dport 1337 -j DNAT --to-destination 5.45.100.191:1337

but thats not working, i think its connecting but it keeps spamming a system #random number# message.[/quote]

I tried using a socks proxy combined with ssh forwarding. It turns out that this combination worked - at least for me. I did this on a Windows machine, but with Linux you should be able to do the same

ssh localhost -L 1337: beeeeer.org:1337 -N
and start the miner with 
primeminer -pooluser=yourAddressHere -poolpassword=0 -poolip=127.0.0.1 -poolport=1337 -genproclimit=whateverSuitsYourNeeds

I haven’t tried this, but maybe you want to? ;)[/quote]

Same, no error - just System:113 every few seconds…i think i have to read into iptables and masquerade my connection…something like that ^^


#12

There was a space in the command - you didn’t fall into that trap? I guess no, there should be an error message…
“Correct” (not that correct as it still doesn’t work :frowning: ) version:

ssh localhost -L 1337:beeeeer.org:1337 -N

#13

I can`t install miner on Ubuntu 10.04.

root@dorret:~# sudo apt-get install git g++ libboost-all-dev libdb++-dev build-essential libgmp-dev libssl-dev Reading package lists... Done Building dependency tree Reading state information... Done Package git is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package git has no installation candidate
without these packages miner is not compiled

Need help for noob(me). :’(


#14

[quote=“Boo-Boo, post:13, topic:358”]I can`t install miner on Ubuntu 10.04.

root@dorret:~# sudo apt-get install git g++ libboost-all-dev libdb++-dev build-essential libgmp-dev libssl-dev Reading package lists... Done Building dependency tree Reading state information... Done Package git is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package git has no installation candidate
without these packages miner is not compiled

Need help for noob(me). :’([/quote]

Ubuntu 10.04 is rather old. maybe you nee git-core instead? And if you are already logged in as root, “sudo” is not necessary.

apt-get install git-core

#15

[quote=“masterOfDisaster, post:14, topic:358”]Ubuntu 10.04 is rather old. maybe you nee git-core instead? And if you are already logged in as root, “sudo” is not necessary.

apt-get install git-core [/quote]

root@dorret:~# apt-get install git-core Reading package lists... Done Building dependency tree Reading state information... Done The following extra packages will be installed: libdigest-sha1-perl liberror-perl Suggested packages: git-doc git-arch git-cvs git-svn git-email git-daemon-run git-gui gitk gitweb The following NEW packages will be installed: git-core libdigest-sha1-perl liberror-perl 0 upgraded, 3 newly installed, 0 to remove and 3 not upgraded. 1 not fully installed or removed. Need to get 6,193kB of archives. After this operation, 12.9MB of additional disk space will be used. Do you want to continue [Y/n]? y Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid/main liberror-perl 0.17-1 [23.8kB] Get:2 http://us.archive.ubuntu.com/ubuntu/ lucid/main libdigest-sha1-perl 2.12-1build1 [26.7kB] Get:3 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main git-core 1:1.7.0.4-1ubuntu0.2 [6,143kB] Fetched 6,193kB in 13s (464kB/s) Selecting previously deselected package liberror-perl. (Reading database ... 43649 files and directories currently installed.) Unpacking liberror-perl (from .../liberror-perl_0.17-1_all.deb) ... Selecting previously deselected package libdigest-sha1-perl. Unpacking libdigest-sha1-perl (from .../libdigest-sha1-perl_2.12-1build1_amd64.deb) ... Selecting previously deselected package git-core. Unpacking git-core (from .../git-core_1%3a1.7.0.4-1ubuntu0.2_amd64.deb) ... Processing triggers for man-db ... fopen: Permission denied Setting up grub-pc (1.98-1ubuntu13) ... Generating grub.cfg ... /usr/sbin/grub-probe: error: cannot find a GRUB drive for /dev/xvda1. Check your device.map. dpkg: error processing grub-pc (--configure): subprocess installed post-installation script returned error exit status 1 Setting up liberror-perl (0.17-1) ... Setting up libdigest-sha1-perl (2.12-1build1) ... Setting up git-core (1:1.7.0.4-1ubuntu0.2) ... Errors were encountered while processing: grub-pc E: Sub-process /usr/bin/dpkg returned an error code (1)

root@dorret:~# sudo apt-get install g++ libboost-all-dev libdb++-dev build-essential libgmp-dev libssl-dev Reading package lists... Done Building dependency tree Reading state information... Done E: Couldn't find package libgmp-dev


#16

[quote=“xolokram, post:9, topic:358”]@mhps:
install boost library

sudo apt-get install libboost-all-dev
or for everything:
sudo apt-get install git g++ libboost-all-dev libdb+±dev build-essential libgmp-dev libssl-dev

(it’s recommended to build the gmp library from scratch with the latest version)[/quote]

Thanks. It compiles nicely.


#17

[quote=“Boo-Boo, post:15, topic:358”][…]
E: Couldn’t find package libgmp-dev[/quote]
Looks like to have to download it and compile it on your own… (or you find a compatible installer package)
-> http://gmplib.org/


#18

There was a space in the command - you didn’t fall into that trap? I guess no, there should be an error message…
“Correct” (not that correct as it still doesn’t work :frowning: ) version:

ssh localhost -L 1337:beeeeer.org:1337 -N [/quote]

Yeah i noticed the space ;D gave me an error, removed it, still not working - miner doesn’t say he can’t connect, just getting no work :frowning:

I tried to forward via iptables plus masquerade that port in postroute rules but with the same result - that should in theory work though :’(


#19

@Boo-Boo:
Lucid is really really old, if you don’t want to compile it (which is actually recommended, but more difficult), try to install the packages…
libgmp3-dev
libgmpxx4ldbl

the names for packages change sometimes (from one release to the next). check:
http://packages.ubuntu.com/ (ubuntu)
or
http://www.debian.org/distrib/packages (debian)

@Sy:
sorry, i’m not to familiar with masquerading via iptables. last time i used this is years ago :slight_smile:
maybe someone else can help.

  • xolokram

#20

[quote=“masterOfDisaster, post:12, topic:358”]“Correct” (not that correct as it still doesn’t work :frowning: ) version:

ssh localhost -L 1337:beeeeer.org:1337 -N [/quote]

After compiling the miner on ubuntu I found it being able to start but just stuck there and not working. I suspect the miner was not communicating to the server so I tried your method. It didn’t work. Then I realized the 1337 port might be too low to be allowed on the local system (a virtual machine), so I changed it to

ssh localhost -L 11337:beeeeer.org:1337 -N
[code] primeminer -pooluser=... -poolpassword=0 -poolip=localhost -poolport=11337 -genproclimit=... [/code] and it starts to mine.

I suggest beeeeer.org use a port number greater than 10000 in the future.

edit: The miner finds a lot of “Probable prime chains” but there are only a few
[MASTER] submitted shares --> SHARE
Why is that?