(Problem Solved) Forum Not Loading With Mobile LTE Connection, Please Help


#1

Ok, so I mentioned this in the other thread, but I’m personally having a technical issue with the forum and I was wondering if any of you can help test it to make sure it’s not just me.

I have an iPhone 6+ that runs on the Sprint network. I’m also using the default safari browser. When I’m on wifi at home, at work or I’m close to a wifi hotspot from my internet provider Comcast, this forum loads just fine.

However, as soon as I drive anywhere else and I don’t have access to wifi and I’m running off of Sprint’s LTE network, the forum will not load at all. I have tried for the past 5 days and nothing has changed. It never loads when it says LTE on the screen.

I tried going to safari’s options and clearing all history and website data, but that had no effect. I also tried downloading the mobile Chrome browser and it didn’t work on there either, same thing.

Maybe it’s a DNS issue or something? I was wondering if any of you guys could try testing what I’m talking about. Let me know what kind of phone you’re using, what mobile carrier, If it said LTE on the screen and did it actually load or not.

Besides that, does anybody have any guesses as to what it could be or something I could try? My phone is not jail broken and I’m using the following URL to access the forum: https://talk.peercoin.net

Any help would be great, thanks!


#2

#3

My guess would be DNS. Try changing DNS settings, for start test with Google’s DNS server 8.8.8.8.


#4

I think there is definitely a problem with the site’s DNS settings, not something on my end. I tried resetting network settings on my phone and nothing changed. So I tried loading the forum on my desktop PC using Edge, Chrome and FireFox using this domain: https://talk.peercoin.net/ All three worked fine.

I tried again using www.talk.peercoin.net. Again, all three worked fine.

However, I again tried all three this time adding www. to the URL: https://www.talk.peercoin.net/ Chrome worked fine, but Edge and FireFox would not load. Here are the error screens in the same order top to bottom…

After seeing it not work correctly on my desktop, I tried a couple more tests on my iPhone. While connected to LTE I tried both https://talk.peercoin.net/ and https://www.talk.peercoin.net/. Neither would load at all, just a white error screen.

Then I connected to my wifi and tried https://www.talk.peercoin.net/, which has been working and worked this time as well. However when I tried https://www.talk.peercoin.net/ I got this, which was new…

So I believe something is definitely wrong. I’m just not sure what it is. Do you have any ideas?


#5

In the last screen I tried hitting details and this came up…

I remember we had a problem with Let’s Encrypt not being fully supported by browsers with peercoin.chat, but wasn’t that solved a while ago?


#6

I clicked on the error code link on FireFox and it said this…

Unable to communicate securely with peer: requested domain name does not match the server’s certificate.

HTTP Strict Transport Security: false
HTTP Public Key Pinning: false

Followed by lots of numbers and letters.


#7

This can only mean that Safari (or iOS) did not include the Let’s Encrypt in the valid SSL whitelists.

https://discussions.apple.com/thread/7785431


#8

What about the errors on Edge and FireFox Desktop browsers?

Edit: In your image above you did not include the www. That is how it stopped working for me. Try using this link https://www.talk.peercoin.net/ instead of this one: https://talk.peercoin.net/


#9

I also have no issue with peercoin.chat which uses Let’s Encrypt also. Wouldn’t it not work correctly for both sites if that was the case instead of just one?


#10

I am not sure, but I’ve just linked you the screenshot of my Firefox. Which correctly recognizes the certificate and all is fine. Proper url for this forum is talk.peercoin.net.

Options for tweaking this SSL stuff with discourse are very very limited. Installation and configuration comes down to editing a single file and hoping all will turn out well once started.

It is vastly different than what I did with peercoin.chat where I’ve manually setup rocket.chat instance, nginx, let’s encrypt certificates and used openssl to calculate diffie hellman groups and import them in the nginx.


#11

I guess I will have to wait until Apple realizes it and fixes it then.


#12

Maybe bump them via support forum or give them a call?


#13

I just replied with my similar issue.


#14

Known Compatible

  • Safari >= v4.0 on macOS
  • Safari on iOS >= v3.1

#15

So basically I’m waiting for Apple to resolve the incompatibility?


#16

There shouldn’t be an incompatibility. iPhone 6 shipped with iOS 8, which is >= 3.1. I wonder why you have this issue. My iPhone 6s on iOS 10.2 loads https://talk.peercoin.net on LTE without issue.


#17

Have you tried adding the www. in there just to see what happens? https://www.talk.peercoin.net

As I showed above in my screenshot I get a server identity error message when trying that. However, I only just tried that this morning. I’ve been using it without the www. and it just gives me the white page error that says safari cannot open the page.

I’m not sure if the error I get when adding in the www. is related with the error I get when not including it. Try it out real quick and tell me if it loads fine for you or if there is an issue. Just add it in right after the https://


#18

Adding www. brings the error, which is expected because the certificate is not issued for that domain. I don’t expect that to be a problem for people. If someone types www.talk.peercoin.net in their browser they’ll connect over HTTP and be redirected to talk.peercoin.net unless they force HTTPS improperly. Nobody will type https://www.talk.[…]. Do you want to use www.talk.peercoin.net in marketing?

Still, why can you not load https://talk.peercoin.net ….


#19

this appears to be a known issue with not supplying the full certificate chain


#20

@Sentinelrv: Can you load the test instance I have running?