(Problem Solved) Forum Not Loading With Mobile LTE Connection, Please Help


#21

With wifi I can, LTE nope, same as this forum.


#22

I already explained to Jooize via PM that I was wrong about this. It was working, I just didn’t have a strong enough LTE connection. After I posted this I noticed other websites weren’t working either that normally work, so I just had a weak signal at the moment of testing. I retested once I got a stronger signal and his test forum loaded with no issues.

@jooize, are you using Let’s Encrypt for your test forum? If so, what did you do different?


#23

Why did you ask me to try loading your test forum? Is something different about it?


#24

Certificate is rated A+
https://www.ssllabs.com/ssltest/analyze.html?d=talk.peercoin.net


#25

I see no difference in the certificates comparing at SSL Labs. The test forum doesn’t include the whole certificate chain either. It uses Let’s Encrypt via Discourse’s built-in template.

These are the commands I run to enable Let’s Encrypt after Discourse is set up with DigitalOcean’s One-click apps.

letsencrypt_account_email="<email>"

sed -i.bak "s/^.*\(- \"templates\/web\.ssl\.template\.yml\"\)$/  \1/; s/^.*\(- \"templates\/web\.letsencrypt\.ssl\.template\.yml\"\)$/  \1/; s/^.*\(LETSENCRYPT_ACCOUNT_EMAIL:\).*$/  \1 ${letsencrypt_account_email}/" /var/discourse/containers/app.yml
/var/discourse/launcher rebuild app
/var/discourse/launcher rebuild app
cd /var/discourse/shared
ln -s standalone/ssl ssl
/var/discourse/launcher restart app

It works over Wi-Fi …. I have no idea. Can anyone else with iPhone 6 on Sprint try https://talk.peercoin.net on cellular connection (LTE)?


#26

So basically I can load the test forum here…

https://discourse.test.peercoin.network/?mobile_view=0

…but not this forum…

https://talk.peercoin.net/

…and they’re both using Let’s Encrypt. Something has to be different between them right?


#27

Ok, I might have made some progress. Pretty much my whole family uses various smart phones through the Sprint network. I asked them all to try it without wifi and nobody could load it. My brother and his girlfriend have the same exact phone, he’s on Sprint and she is on AT&T, yet only she was able to load it.

So I’m thinking that Sprint might be the cause, which would make sense because wifi works. It’s only when I try to load it through the Sprint network that it fails. Peerchemist thinks maybe they might have a routing issue or something, so I will try getting in touch with them. If anybody here has Sprint, please let me know, thanks!


#28

@peerchemist, what did you do? It suddenly started working through the Sprint network. I haven’t tested it in a while, so I’m not sure when the issue was fixed.


#29

all is same, just rebooted last night.

(last time config was changed was over a month ago, I think I fixed it back then.)