No minting going on for months now

Can anyone confirm they can mint properly using the Peercoin windows client (0.9). I have rebuilt the blockchain (twice now!), made sure connections are working, wallet is unlocked etc. Have been successfully minting for several years with earlier versions but I have had nothing so far.

Thoughts? thanks!

I haven’t encountered any issues myself. I’m usually able to mint multiple times per day, so no difference from v0.8.

1 Like

Hmmmm , not been able to mint for a long time now… I have the client running constantly… Maybe I need to create a new wallet and transfer coins to it? Last time I minted was in May 2020… since then, nothing…

can you find anything from debug.log that could give you a clue?

Nothing in the log I can see… I can post the log if that helps?

I say backup your wallet, delete the chain and resync.
cheap solution but it might work.

if it is minting it should say somewhere in the logs, and if it finds a block, or orphaned…, is your system clock correct and everything?

Maybe you simply can’t compete at current PoS difficulty? Check minting tab for chance to mint in next 30 days.

The PoS difficulty has increased since the v0.9 hardfork. That could be the issue.

Chance to complete in next 30 days is 86%… I’ve installed the wallet on a clean computer and dropped the wallet.dat file into the user directory and leaving it sync up…

1 Like

if you have your old debug.log please send it to

Thanks, File sent

Any luck? Still no minting on my end

Have you tried resyncing? Close the client, backup your wallet, delete the entire peercoin folder (%appdata% on windows), and reopen the client.

Does anyone know if findstake.js is currently working? It might be a good way for you to check when your next minting window is.

Yes i tried this, and I also installed the Peercoin client on a new computer and it isn’t minting on the new one as well… (been a few days now I’ve left it running)…

All that is going on here is that PoS diff is high. It’s 10.76 at the moment.

1 Like

11.09 today lol.

Still nothing minted… I used to have a reward every other day… its literally been months. Are you sure this isnt a bug/fault?

Check that you have the same block height as here:

I’ve been minting fine. How many connections do you have? You should have over 8. Maybe its a firewall thing?

1 Like

Yes, same block height, and 8 connections’

Log below:
2020-09-07 15:44:59 init message: Rewinding blocks…
2020-09-07 15:45:00 init message: Verifying blocks…
2020-09-07 15:45:00 Verifying last 6 blocks at level 3
2020-09-07 15:45:00 [0%]…[16%]…[33%]…[50%]…[66%]…[83%]…[99%]…[DONE].
2020-09-07 15:45:00 No coin database inconsistencies in last 7 blocks (22 transactions)
2020-09-07 15:45:00 block index 6473ms
2020-09-07 15:45:00 init message: Loading wallet…
2020-09-07 15:45:00 nFileVersion = 160300
2020-09-07 15:45:00 Keys: 0 plaintext, 1231 encrypted, 0 w/ metadata, 1231 total
2020-09-07 15:45:00 wallet 36ms
2020-09-07 15:45:00 setKeyPool.size() = 0
2020-09-07 15:45:00 mapWallet.size() = 720
2020-09-07 15:45:00 mapAddressBook.size() = 0
2020-09-07 15:45:00 mapBlockIndex.size() = 519331
2020-09-07 15:45:00 nBestHeight = 519317
2020-09-07 15:45:00 Imported mempool transactions from disk: 0 succeeded, 0 failed, 0 expired, 0 already there
2020-09-07 15:45:00 torcontrol thread start
2020-09-07 15:45:00 Bound to [::]:9901
2020-09-07 15:45:00 Bound to
2020-09-07 15:45:00 init message: Loading P2P addresses…
2020-09-07 15:45:00 Loaded 16022 addresses from peers.dat 56ms
2020-09-07 15:45:00 init message: Loading banlist…
2020-09-07 15:45:00 init message: Starting network threads…
2020-09-07 15:45:00 net thread start
2020-09-07 15:45:00 dnsseed thread start
2020-09-07 15:45:00 init message: Done loading
2020-09-07 15:45:00 addcon thread start
2020-09-07 15:45:00 msghand thread start
2020-09-07 15:45:00 opencon thread start
2020-09-07 15:45:00 ThreadStakeMinter started
2020-09-07 15:45:00 GUI: Platform customization: “windows”
2020-09-07 15:45:00 CPUMiner started for proof-of-stake
2020-09-07 15:45:00 Set proof-of-stake timeout: 923ms for 199 UTXOs
2020-09-07 15:45:00 PeercoinMiner runtime error: No coinbase script available (mining requires a wallet)
2020-09-07 15:45:00 ThreadStakeMinter exiting
2020-09-07 15:45:00 GUI: PaymentServer::LoadRootCAs: Loaded 56 root certificates
2020-09-07 15:45:00 refreshWallet
2020-09-07 15:45:01 Leaving InitialBlockDownload (latching to false)
2020-09-07 15:45:01 New outbound peer connected: version: 70015, blocks=519318, peer=0