Discrepancy between blockchain explorer and Peerunity

Why is https://peercoin.mintr.org/ showing me a different balance than my Peerunity wallet??

There is one large transaction that appears there that doesn’t show up in Peerunity.

Try “peercoind -rescan”

I’m also having Peerunity issues. Just installed Unity a few days ago to try to fix older wallet issues. Install went great. Unity is currently stuck downloading the blockchain at block 234033. I tried closing out the wallet and reopening, as well as a wallet close, computer reboot, and opening the wallet back up. I tried looking into debug and console commands and I was not able to find a proper command. What am I missing? I also tried the above sugestion of “peercoind -rescan”. I tried typing that into console as well as a copy and paste. Console returned a “Method not found (code -32601”). How do I get Unity to download the whole blockchain. Thank you. Please help.

I’m having same issue. The coin amount in PeerUnity is different than the coin amount on blockchain. I downloaded blockchain again, it comes up with the incorrect value again. Tried to -rescan but says Method not found, code -32601. Running Windows 7, 64 bit.

Make sure to update to the latest version of Peerunity here: https://github.com/Peerunity/Peerunity/releases

The latest version is: 0.2.2

Thank you for your prompt response. I already have that version, and just reinstalled it and redownloaded the blockchain again with the same result. Any other ideas?

Don’t type it in a client console. open a operating system console, cd to peerunity directory, and type ./ppcoind -rescan there. Change ppcoind to daemon/peerunityd if you don’t find ppcoind but you find daemon directory in peerunity dir.

I think my issue might have to do with funds being transferred to my change address. How do I see what change addresses I have in my wallet?

Thanks for the response. Unfortunately I’m not as computer literate as yourself. I’m using a mac. My best understanding of what I need to do is go into Terminal and type in the stuff you recommended to type. I tried but once again I’m lost in computer tech translation and I lack the knowledge for command line stuff in Terminal to force a rescan. If possible can you break it down barney style and do a step by step of what I need to do in Terminal? I sent a pm or can someone else as knowledgeable send me a step by step break down in pm or post here. Thank you.

My balance was also incorrect when I loaded my old wallet with the new client. Under menu ‘help’ there is a debug console option. There, try the following 2 commands:
Then quit and restart the client

I am typing what you say in the command prompt for my Peerunity directory but it is not working. It is a daemon directory. I type “./daemon/peerunityd -rescan”, “./daemon -rescan”, “/daemon/peerunityd -rescan”, etc etc. I don’t know what to do from here. No combination I have tried has resulted in a successful input.

I tried in the client console “checkwallet” and “repairwallet”, both of which were “true”, and upon restart of the program, the amount was still incorrect.

Could you make this any simpler? Sorry for my ignorance.

did you do it in the peerunity directory where you can see blk0001.dat ?
you should type ./daemon/peerunityd -rescan.

I suspect you diid what you did in daemon directory. If you already are in daemon directory, just type ./peerunityd -rescan

“./” means the current directory which you are in.

I went into the daemon directory and typed “peerunityd -rescan” because my cmd prompt will not accept an input beginning with “.”

It was thinking for a couple minutes and said:
Error: To use peerunity(ppcoind), you must set a rpcpassword in the configuration file:

then lists an rpcuser and rpc password I should use, a password it says I need not remember.

Just to be sure, I then got back onto Peerunity and the amount is still incorrect.

you need to make a file in peerunity dir called either ppcoin.conf or peerunity.conf (i am not sure which ) put these two lines in it, change xxx yyy to whatever


So sorry, I guess I don’t know how to make a .conf file. I go into Notepad and it just saves it as “ppcoin.conf.txt” The internet says this is how you’re supposed to do it, through Notepad. What am I doing wrong?

Just ppcoin.conf, drop the .txt

Okay, so I managed to get the .conf file. I’m making painfully slow progress.

Now, I type the rescan command and I get this:

Error: To use peerunity(ppcoind), you must set a rpcpassword in the configuration file:
<ppcoin.conf file address>
It is recommended you use the following random password:
If the file does not exist, create it with owner-readable-only file permissions.

I doubled checked the conf file, it has exactly what you told me to put into it. No misspellings. Plus the long random password the program recommended I use.

make sure the file is in the peerunity directory where blk0001.dat is…
in the peerunity dir, enter this command to make the config not readable to others
chmod 400 peerunity.conf
if this doesn’t help, try, in peerunity dir,
```daemon/peerunityd --datadir=. --conf=./peerunity.conf````

Sorry, I’m sure this is as frustrating for you as it is for me. When I type in the directory in which blk0001.dat resides: “chmod 400 peerunity.conf”, I get this message:
‘chmod is not recognized as an internal or external command, operable program or batch file’

And is it supposed to be “peerunity.conf”? Not ppcoin.conf? I made the file “ppcoin.conf”

Would you please tell me exactly what to type in quotations? Within the blk0001.dat directory? I don’t even know where to begin with the daemon/peerunityd directive you have given me.

forget it then.

As I said I can’t remember which. You should try both.

when people use this font,

like this

it means you should type exactly.

So in peerunity dir, type

daemon/peerunityd --datadir=. --conf=./ppcoin.conf --rescan

note that what follows --conf= is the config file

edit: i forgt the rescan