Cgminer.conf example file for Peercoin mining


#1

{
“pools” : [

{
	"url" : "http://ppc.fixx.ru:8437",
	"user" : "FuzzyBear.donate",
	"pass" : "password"
}

]
,
“intensity” : “9”,
“vectors” : “1”,
“worksize” : “64”,
“kernel” : “poclbm”,
“lookup-gap” : “0”,
“thread-concurrency” : “0”,
“shaders” : “0”,
“gpu-engine” : “0-0”,
“gpu-fan” : “0-100”,
“gpu-memclock” : “0”,
“gpu-memdiff” : “0”,
“gpu-powertune” : “0”,
“gpu-vddc” : “0.000”,
“temp-cutoff” : “75”,
“temp-overheat” : “65”,
“temp-target” : “55”,
“api-port” : “4028”,
“expiry” : “120”,
“failover-only” : true,
“gpu-dyninterval” : “5”,
“gpu-platform” : “0”,
“gpu-threads” : “1”,
“hotplug” : “5”,
“log” : “5”,
“no-pool-disable” : true,
“queue” : “5”,
“scan-time” : “20”,
“temp-hysteresis” : “3”,
“shares” : “0”,
“kernel-path” : “/usr/local/bin”
}


#2

For comparison here is my configuration for BFL SCs:

{
“pools” : [
{
“url” : “ppc.fixx.ru:3333”,
“user” : “user.1”,
“pass” : “12345”
}
],
“api-listen” : true,
“api-port” : “4028”,
“api-allow” : “W:127.0.0.1”,
“no-pool-disable” : true,
“queue” : “2”,
“scan-time” : “60”,
“shares” : “0”,
“kernel-path” : “/usr/local/bin”,
“icarus-options” : “115200:1:1”,
“icarus-timing” : “3.0=100”,
“auto-fan” : false,
“auto-gpu” : false,
“expiry” : “120”,
“failover-only” : true,
“gpu-threads” : “2”,
“log” : “5”
}

Executed with “cgminer --config /home/pi/cgminer-asic.conf --avalon-auto --quiet --usb :3”


#3

How would you configure it for 3 BFL Jalapenos? New to mining. I could really use a video tutorial.


#4

cgminer should automatically detect ur BFL devices … if u have 3 running it will pick up 3.

Have you got the BFL devices mining individually? u need to install a driver directly on the device you know?

Fuzzybear


#5

Are you mining with Windows or Linux?

If it is Linux, such as a Raspberry Pi, then you need to install new USB drivers.

There is a good set of instructions for a Pi (which I used) at http://dominustemporis.com/2013/06/compiling-cgminer-for-the-raspberry-pi-and-butterflylabs-jalapeno/ this walks though the steps needed. It is the same for Peercoin as Bitcoin just make sure the pool details are correct.


#6

I’m trying to set up peercoin mining with a nvidia quadro 1000M gpu.

I’d tried setting up the config file as

{
“pools” : [

{
“url” : “http://stratum.d7.lt”,
“user” : “mcwrenn21.1”,
“pass” : “12345”
}

]
,
“intensity” : “9”,
“vectors” : “1”,
“worksize” : “64”,
“kernel” : “poclbm”,
“lookup-gap” : “0”,
“thread-concurrency” : “0”,
“shaders” : “0”,
“gpu-engine” : “0-0”,
“gpu-fan” : “0-100”,
“gpu-memclock” : “0”,
“gpu-memdiff” : “0”,
“gpu-powertune” : “0”,
“gpu-vddc” : “0.000”,
“temp-cutoff” : “75”,
“temp-overheat” : “65”,
“temp-target” : “55”,
“api-port” : “4028”,
“expiry” : “120”,
“failover-only” : true,
“gpu-dyninterval” : “5”,
“gpu-platform” : “0”,
“gpu-threads” : “1”,
“hotplug” : “5”,
“log” : “5”,
“no-pool-disable” : true,
“queue” : “5”,
“scan-time” : “20”,
“temp-hysteresis” : “3”,
“shares” : “0”,
“kernel-path” : “/usr/local/bin”
}

and my .bat file that i use to start the miner looks like

cgminer -o http://stratum.d7.lt:3333/ -u mcwrenn21.1 -p 12345

When it runs this is what I get:

Started cgminer 3.8.0
Loaded configuration file cgminer.conf
No devices detected!
Waiting for USB hotplug devices or press q to quit
Too many values passed to set temp cutoff

When I run it without the config file that I created it just connects (i think)
But doesn’t do anything…
However i don’t get the “too many values passed to set temp cutoff” problem

I really have no idea what I’m doing, very little experience mining and minimal programming.

I’ve tried GUIminer, and it detects my gpu. But it can never connect to the pool.

I can get my cpu to mine with cgminer, but the hash rate is too lower and I only get invalid shares.

Any help is appreciated! Is there a simple way to get this to work?


#7

I’d need to look into cgminer further… but there was a thread i read that GPU support was being removed… u may want to try cgminer 3.5 and see if that makes a difference

Fuzzybear


#8

Hello I’ve tried using your recommended config but modified to match my GPU a bit better.

For some reason I’m getting an error that reads “cgminer: --config: JSON decode of file ‘cgminer.conf’ failed
string or ‘}’ expected near ‘}’”

Now from my basic understanding of programming this would mean that i’m missing an end bracket for a beginning bracket or vice versa however unless i’m going blind this doesn’t seem to be the case. Does anyone have any ideas? Below is my entire config file, minus password.

[code]{
“pools” : [

{
“url” : “tcp://stratum.d7.lt:3333”,
“user” : “Sylentwolf8.380”,
“pass” : “password”
}

],

“intensity” : “9”,
“vectors” : “1”,
“worksize” : “256”,
“lookup-gap” : “0”,
“thread-concurrency” : “0”,
“shaders” : “1024”,
“gpu-engine” : “680”,
“auto-fan” : true,
“gpu-memclock” : “900”,
“gpu-memdiff” : “0”,
“temp-cutoff” : “75”,
“temp-overheat” : “65”,
“temp-target” : “60”,
“failover-only” : true,
“gpu-threads” : “2”,
“no-pool-disable” : true,
“queue” : “5”,
“scan-time” : “20”,
“temp-hysteresis” : “3”,
}[/code]


#9

[quote=“Sylentwolf8, post:8, topic:734”]For some reason I’m getting an error that reads “cgminer: --config: JSON decode of file ‘cgminer.conf’ failed
string or ‘}’ expected near ‘}’”

"temp-hysteresis" : "3", }[/quote]

This trailing comma at the end bugs me, I don’t know if that’s it, but…


#10

[quote=“ppcman, post:9, topic:734”][quote=“Sylentwolf8, post:8, topic:734”]For some reason I’m getting an error that reads “cgminer: --config: JSON decode of file ‘cgminer.conf’ failed
string or ‘}’ expected near ‘}’”

"temp-hysteresis" : "3", }[/quote]

This trailing comma at the end bugs me, I don’t know if that’s it, but…[/quote]

That seems to have fixed it thanks, however unfortunately a new issue has occurred where cgminer simply stops working as soon as it (presumably) goes through the authentication process for the pool. Have you or anyone had a similar issue?


#11

Is there a thread one could go to who is brand new to mining and is looking to join a pool to mine with CGMiner?

The config that is posted above, do I just copy and paste it into CGminer to get started? I am beyond new and pretty frustrated. :smiley:


#12

[quote=“BabylonDown, post:11, topic:734”]Is there a thread one could go to who is brand new to mining and is looking to join a pool to mine with CGMiner?

The config that is posted above, do I just copy and paste it into CGminer to get started? I am beyond new and pretty frustrated. :D[/quote]

Nope, you wouldn’t want to just copy and paste it in. What you need to do is create a config file. Just open notepad, and save the file named cgminer.config inside of your cgminer folder. That file would contain the config posted above. You may have to tweak some of the values in it however to match your GPU.


#13

Alright. Just created a config file and put it in my CGMiner folder.

I was under the impression that PPC and XMP were only working for CPU mining?


#14

Alright. Just created a config file and put it in my CGMiner folder.

I was under the impression that PPC and XMP were only working for CPU mining?[/quote]

I can’t really confirm or deny that, and if that is true it might explain why my cgminer is crashing every time I try to mine PPC.


#15

Hehe. One more question. Do I have to follow the Windows Readme file in CGMiner? Including downloading Mingw32, libpdcurses etc?


#16

I did not have to do this to mine BTC/LTC/FTC so I would assume not. To be honest I’ve never even heard of those files.


#17

Alright. It seemed way too confusing and complicated anyways. :smiley:

Now I’m just trying to get CGMiner to recognize my CPU. It says “No deviced Detected!” I’m running a 3770k. Any ideas?


#18

[quote=“BabylonDown, post:17, topic:734”]Alright. It seemed way too confusing and complicated anyways. :smiley:

Now I’m just trying to get CGMiner to recognize my CPU. It says “No deviced Detected!” I’m running a 3770k. Any ideas?[/quote]
days of mining SHA-256 coins with your CPU are long gone I am afraid my friend. You want to look into Primecoin and Xolo’s miner listed on this forum.

cgminer is used now for GPU, FPGA’s and ASIC mining… and they are stopping the GPU support I believe

Fuzzybear


#19

Miner with CPU.

minerd.exe -o stratum+tcp://ppc.fixx.ru:8437 -u . -p

Mine is Work. Hope Help you. :wink:


#20

is there a topic about seting up a pool, I am trying to do that, but something wrong with ppc