[ANN] Peerbox project

#141

Peerchemist, would you mind elaborating a bit on your concerns with PUTTY? Are there any security concerns? I’ve never encountered problems using it before.

#142

After peercoin on raspberry pi, peerbox, finally.

Awesome tutorial. Tks peerchemist

#143

Peerchemist, would you mind elaborating a bit on your concerns with PUTTY? Are there any security concerns? I’ve never encountered problems using it before.[/quote]

quick google search “putty security” will link you many topics on that subject.
It seems all bugs have been fixed, but if you roam various security/privacy forums in search of knowledge like I do you you’ll probably find people saying Putty is bad software (bad quality) and there are better alternatives.
So, I think it is better to avoid problems from start by telling people to use something better.

#144

OK, I can’t disagree with that. Personally, I still like PuTTY when I’m on Windows because it’s essentially portable and I can carry my keys in a .reg file.

Anyway, I just got my RasPi node up thanks to Peerbox. Backing up my wallet was a little confusing at first because of permissions issues, but I appreciate the concern for security. I know you already have plans to make it even more user friendly- you’ve done amazing work!

#145

tunnelier’s ssh seems much better than putty

#146

Since a few days ago, I cannot get to run ppcoind correctly any more.
Weird.
htop says: [6613 ppcoind 20 0 73664 46256 19276 R 96.1 9.4 0:13.17 /usr/bin/ppcoind -daemon -conf=/etc/peercoin/peercoin.conf -pid=/run/ppcoind/ppcoind.pid -datadir=/var/lib/ppcoind -loadblock=blk0001.dat]

But peerbox-info -a says [{
“ppcoind”: “ppcoind inactive”,
“system”: {
“average load”: [
1.07,
0.96,
0.96
],
“board_rev”: “0xe”,
“hardware”: “Raspberry Pi”,
“kernel release”: “3.14.6-3-GRSEC”,
“maccaddr”: “B8:27:EB:01:8A:1E”,
“peerbox”: “0.22”,
“serial”: “00000000c5018a1e”,
“system_temperature”: 46.54,
“uptime”: “18:35:40.120000”
}
}
]

I tried several times to stop and start ppcoind with systemctl but no chance.
Also /etc/peercoin/peercoin.conf looks fine.

Should I rewrite a fresh image?

#147

[quote=“cryptog1, post:146, topic:2485”]Since a few days ago, I cannot get to run ppcoind correctly any more.
Weird.
htop says: [6613 ppcoind 20 0 73664 46256 19276 R 96.1 9.4 0:13.17 /usr/bin/ppcoind -daemon -conf=/etc/peercoin/peercoin.conf -pid=/run/ppcoind/ppcoind.pid -datadir=/var/lib/ppcoind -loadblock=blk0001.dat]

But peerbox-info -a says [{
“ppcoind”: “ppcoind inactive”,
“system”: {
“average load”: [
1.07,
0.96,
0.96
],
“board_rev”: “0xe”,
“hardware”: “Raspberry Pi”,
“kernel release”: “3.14.6-3-GRSEC”,
“maccaddr”: “B8:27:EB:01:8A:1E”,
“peerbox”: “0.22”,
“serial”: “00000000c5018a1e”,
“system_temperature”: 46.54,
“uptime”: “18:35:40.120000”
}
}
]

I tried several times to stop and start ppcoind with systemctl but no chance.
Also /etc/peercoin/peercoin.conf looks fine.

Should I rewrite a fresh image?[/quote]

sudo systemctl start ppcoind
sudo systemctl status -l ppcoind

Then please post here.

#148

peerchemist, this is what i ve got:

  • ppcoind.service - PPCoin Daemon
    Loaded: loaded (/usr/lib/systemd/system/ppcoind.service; enabled)
    Active: active (running) since Wed 2014-09-24 10:01:04 BST; 2s ago
    Process: 7849 ExecStart=/usr/bin/ppcoind -daemon -conf=/etc/peercoin/peercoin.conf -pid=/run/ppcoind/ppcoind.pid -datadir=/var/lib/ppcoind $ARGS (code=exited, status=0/SUCCESS)
    Main PID: 7850 (ppcoind)
    CGroup: /system.slice/ppcoind.service
    `-7850 /usr/bin/ppcoind -daemon -conf=/etc/peercoin/peercoin.conf -pid=/run/ppcoind/ppcoind.pid -datadir=/var/lib/ppcoind -loadblock=blk0001.dat

Sep 24 10:01:04 peerbox systemd[1]: Started PPCoin Daemon.

#149

ppcoind is running.

try: ppcoind getinfo

If it does not work, check .ppcoin/ for your username/pass maybe something is messed up with that.

#150

I got: [error: couldn’t connect to server] …

#151

Have you tried sudo reboot?

#152

So something is wrong with authentication with ppcoind.

cat .ppcoin/ppcoin.conf

sudo cat /etc/peercoin/peercoin.conf

rpcuser and rpcpassword must match in both files.

#153

willywithcoinnode, I did reboot several times.

peerchemist, the user and password match.

I think my issues is similar to: http://www.peercointalk.org/index.php?topic=3269.0
Maybe I broke the system after modifying a configuration file without stopping the server.

sudo tail --lines 100 /var/lib/ppcoind/db.log gives me:

BDB0126 mmap: Invalid argument

I think I need to reinstall ppcoind. Do you know how can i do that?

#154

[quote=“cryptog1, post:153, topic:2485”]willywithcoinnode, I did reboot several times.

peerchemist, the user and password match.

I think my issues is similar to: http://www.peercointalk.org/index.php?topic=3269.0
Maybe I broke the system after modifying a configuration file without stopping the server.

sudo tail --lines 100 /var/lib/ppcoind/db.log gives me:

BDB0126 mmap: Invalid argument

I think I need to reinstall ppcoind. Do you know how can i do that?[/quote]

What file did you change? Ppcoind should be configured trough /etc/conf.d/ppcoind.conf

Anyway, reinstalling ppcoind:

sudo pacman -S ppcoind
#155

Tks for the tips, peerchemist.
I am redownloading the blockchain now…but it fixed the server connection issue.
I modified /etc/peercoin/peercoin.conf once but reverted to the default configuration later on…

#156

[quote=“mhps, post:97, topic:2485”]With v0.21, upnp status on the router still shows to no openning of port. But manually turning on port forwarding now works! I am getting more than 8 connections now.

By the way, I wish user sunny is in ppcoind group so that I can check debug.log easily.

pps: I tried to log in as sunny from a remote machine and I got permission denied. I hope this is how it is supposed to behave because I don’t want anyone to login remotely (non-local network).[/quote]

Sadly I cannot get more than 8 connections although I have forwarded port 9901 to the Pi IP address…
I could get more than 8 connections with the “Peercoin on Raspberry PI” project.
I noticed that I had to enable [UPnP] on my rooter and my PI was recognized on the UPnP table…
Here [Peerbox project], I am under the same rooter configuration but the PI is not recognized on the UPnP table…
Any setting that I should make regarding /etc/conf.d/ppcoind.conf or /etc/peercoin/peercoin.conf about UPnP?

#157

[quote=“cryptog1, post:156, topic:2485”][quote=“mhps, post:97, topic:2485”]With v0.21, upnp status on the router still shows to no openning of port. But manually turning on port forwarding now works! I am getting more than 8 connections now.

By the way, I wish user sunny is in ppcoind group so that I can check debug.log easily.

pps: I tried to log in as sunny from a remote machine and I got permission denied. I hope this is how it is supposed to behave because I don’t want anyone to login remotely (non-local network).[/quote]

Sadly I cannot get more than 8 connections although I have forwarded port 9901 to the Pi IP address…
I could get more than 8 connections with the “Peercoin on Raspberry PI” project.
I noticed that I had to enable [UPnP] on my rooter and my PI was recognized on the UPnP table…
Here [Peerbox project], I am under the same rooter configuration but the PI is not recognized on the UPnP table…
Any setting that I should make regarding /etc/conf.d/ppcoind.conf or /etc/peercoin/peercoin.conf about UPnP?[/quote]

with portforwarding enabled you dont need UPnP, it should work with both, don’t know if it is possible that they conflict (but that is my guess)

#158

For anyone running a full node or minting using peerbox, I think would be wise to update your bash due to the bash bug that is affecting it.

Peerchemist and other experts, do you recommend a sudo pacman -Syu on all the nodes?

#159

[quote=“GLock, post:158, topic:2485”]For anyone running a full node or minting using peerbox, I think would be wise to update your bash due to the bash bug that is affecting it.

Peerchemist and other experts, do you recommend a sudo pacman -Syu on all the nodes?[/quote]

#160

Thanks for copying it here, I missed entirely those posts