V0.6.2RC2 builds available for testing

Considered it, but don’t see the point in testing the Linux version without the minting option. Perhaps you can motivate me?

The builds I have provided come with minting enabled, it’s not disabled.

Raspbian build:


sha256: 7450ab12495725432e4b92598578a69d4f5ab44519d712a2b88cecc53c9a84e0


Just tried this process on my Ubuntu 16.04. I had the following error after entering the last bit:

The following NEW packages will be installed
0 to upgrade, 1 to newly install, 0 to remove and 29 not to upgrade.
Need to get 3,694 B of archives.
After this operation, 14.3 kB of additional disk space will be used.
Err:1 https://download.opensuse.org/repositories/home:/peerchemist/xUbuntu_16.04 peercoin-qt 0.6.2-1
Protocol “http” not supported or disabled in libcurl
E: Failed to fetch https://download.opensuse.org/repositories/home:/peerchemist/xUbuntu_16.04/./amd64/peercoin-qt_0.6.2-1_amd64.deb Protocol “http” not supported or disabled in libcurl

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Strange as it shows https in the link. Any ideas what this might be about?

I am not sure, it works fine on all of my boxes.

1 Like

Thanks, installing: apt-transport-https indeed solved the issue.

Edit: Or just using http of course

1 Like

Still puzzled: got the repository “peercoin-qt_0.6.2-1_amd64.deb”

But inspecting the path learns that there are only docs, no client in this package:

dpkg --contents peercoin-qt_0.6.2-1_amd64.deb

drwxr-xr-x root/root 0 2018-02-01 13:28 ./
drwxr-xr-x root/root 0 2018-02-01 13:27 ./usr/
drwxr-xr-x root/root 0 2018-02-01 13:27 ./usr/share/
drwxr-xr-x root/root 0 2018-02-01 13:27 ./usr/share/doc/
drwxr-xr-x root/root 0 2018-02-01 13:27 ./usr/share/doc/peercoin-qt/
-rw-r–r-- root/root 6752 2018-02-01 13:17 ./usr/share/doc/peercoin-qt/copyright
-rw-r–r-- root/root 238 2018-02-01 13:17 ./usr/share/doc/peercoin-qt/changelog.Debian.gz

What am I missing? Is there perhaps another package I should get?

Yeah it’s my bad from recent experimentation, I’ll fix it soon.

Hi @peerchemist,

I haven’t been able to test the new peercoin version for raspbian stretch. Had been very busy in the last weeks. But as I would like to test it now, I’d like to ask you whether you can provide me a link to the latest peercoin raspbian build. The old one doesn’t work anymore.


thanks. did you try to install the package on a pi on your own? when I download it and try to intsall it by use of sudo dpkg or also by use of sudo apt-get install the archive cannot be opened/executed. Is the package damaged? can you provide me a checksum of the package to crosscheck if the download was ok?

for me it worked by double clicking on the icon
maybe you have to do chmod +x first?

My nodes are running headless in CLI mode. So I executed it by used of sude dpkg and also by use of sudo apt-get install. I also tried chmd +x, but it doesn’t change anything.

this is the “-qt” client with graphical user interface

But the .deb file is a setup package. So IMHO that shouldn’t matter or am I wrong? I remember executing the peercoin-qt client from CLI via SSH was possible. It opened as a separate application/window outside the SSH client. Or am I mixing something up now? Need to give it a try on my other node.

Then use the daemon package: https://github.com/peercoin/peercoin/releases