Problems with wallet

Hello. I am having following problem with my wallet, which I run under Ubuntu 12.04 64bit. When I go online after some time being offline, the wallet starts syncing. It successfully dowloads the new blocks and the stops stuck somewhere in the process of block validation. The last message in the debug file is something like this:

received block 32d0516f3d9e46b498df ERROR: CheckProofOfStake() : INFO: read txPrev failed WARNING: ProcessBlock(): check proof-of-stake failed for block 32d0516f3d9e46b498df1e8069612b0d1155d38b2d2a8883e922f6f62e842096

At first, I solved it so that I deleted everything but the wallet, but later I figured out that if I close the wallet and reopen it, the program gets past the point where it was previously stuck and gets stuck on new point, or successfully updates all blocks. Now I am running 0.4 wallet, but I was having the same issue with the 0.3 wallet. I append full debug files from such event obtained on testnet.

Any suggestions? Thanks in advance.

when did you upgrade? and did you delete the whole blockchain then redownlod new one… this almost strikes me as you have been trying to mint on the 0.3 version when 0.4 was released as well is this right?

thanks for the feedback and we’ll see if we can isolate the cause of your issue


Thank you, that may very well be it. I didn’t delete the blockchain when I was updating. I will do it and I will write if I’ll observe the problem again.