Peerunity runtime error

I’m keep getting this error when I start up the peerunity application on windows7, this happens with both version 0.1.1 and 0.1.2rc2

I also tried to run this at 2 different PCs and got the same result.

Does this happen when your run the core Peercoin wallet?

Hi [member=28852]kokojie[/member] many thanks for your post and sorry you have had some issues with Peerunity. Hopefully with a little more information we can help you resolve your issue.

I experienced an issue the other day similar to this if my memory is correct when switching between core Peercoin client and the Peerunity client but only in certain instances. As CoinGame asked

  1. “Does this happen when your run the core Peercoin wallet?” and my next question if your answer to that is no it does not happen,
  2. did you load the blockchain fully through core peercoin wallet then tried to launch Peerunity.

If so a restart of the PC may resolve the issue,
secondly if still runtime error, delete the blockchain, let peerunity launch and download the blockchain itself. (remember to keep your wallet.dat file if you have ppc in the wallet)

If none of these work please let me know and where you got the builds from and i’ll see if I can replicate exactly your scenario to cause the error message.


No the blockchain was downloaded thru peerunity, but in one computer the client crashed one day, and somehow corrupted the database, so I kept the “wallet.dat” and deleted everything else, but then I started to have this error show up. I moved the “wallet.dat” file to another PC and ran peerunity from there, and also got the same error.

So I think somehow the “wallet.dat” file is bad and causing a crash? what do I do in this situation? download ppcoin core client?

btw I have done some minting with this wallet, and the wallet file is 784kb big

Ok sounds like your wallet.dat file has become corrupted

looking at this thread as same error message you have but on bitcoin;all

You will want to run Peerunity in debug mode to see more details in the debug.log file

click start,
type cmd
in the command window run something like

 "%ProgramFiles%\Peerunity\Peerunit.exe -debug" 

now look in your %Appdata% folder and locate the ppcoin directory open the debug.log and paste in the last load you have something like…

[code]Bitcoin version 0.5.1-beta
Default data directory C:\Users\NINJA\AppData\Roaming\Bitcoin
Bound to port 8333
Loading addresses… strLogDir=C:\Users\NINJA\AppData\Roaming\Bitcoin/database strErrorFile=C:\Users\NINJA\AppData\Roaming\Bitcoin/db.log
Loaded 0 addresses
addresses 110ms
Loading block index…
CBlock(hash=000000000019d6689c08, ver=1, hashPrevBlock=00000000000000000000, hashMerkleRoot=4a5e1e4baa, nTime=1231006505, nBits=1d00ffff, nNonce=2083236893, vtx=1)
CTransaction(hash=4a5e1e4baa, ver=1, vin.size=1, vout.size=1, nLockTime=0)
CTxIn(COutPoint(0000000000, -1), coinbase 04ffff001d0104455468652054696d65732030332f4a616e2f32303039204368616e63656c6c6f7 2206f6e206272696e6b206f66207365636f6e64206261696c6f757420666f722062616e6b73)
CTxOut(nValue=50.00000000, scriptPubKey=04678afdb0fe5548271967f1a67130)
vMerkleTree: 4a5e1e4baa
SetBestChain: new best=000000000019d6689c08 height=0 work=4295032833
block index 20ms
Loading wallet…

EXCEPTION: 11DbException
Db::open: Invalid argument
C:\Program Files (x86)\Bitcoin\bitcoin-qt.exe in Runaway exception [/code]

I guess I should ask the hopeful question of:

Have you another backup of this wallet?
Do you know the address’s and amounts that the wallet should hold and have seen it on a block explorer?


Thanks, I PMed you the information.

I have back up of the wallet.dat from several month ago, so I think I’m ok, I’ll just restore the old backup if I can’t fix the problem.

start peerunity with no wallet.dat, a new wallet.dat will be created. if everything works fine, shutdown the wallet, wait for a couple of minutes, swap in the old wallet, restart peerunity.