Peercoin v0.6.0 wallet ~empty (0.5PPC)

I have told Sentinelrv

and done like he said here:

but now I have

0.519990 PPC

and I am sure I have had

xxxx.000 PPC

last time I have opened (long time ago)

last transaction I see is Date: 09.05.16 08:05

Status: 0/unconfirmed

what to do?


last I had was:

in /usr/bin
I have tried now with -rescan and have leave it open
now after ~24 hours open nothing happened, still only 0.5 PPC…

Perhaps you synced with a different wallet and maybe moved the one with xxxx.000 PPC into the folder post-sync. I’d suggest running -rescan and see if that helps. Also, if you know your PPC address you can simply check the balance with a blockexplorer while you wait.

1 Like

what is folder post-sync?
had -rescan (see above)
first time I have had this issue was as I have synced with peerunity (think begin of this year)

I see 2017-03-15 made a new folder
(and have folder .ppcoin_old
wallet.dat is Mar 15 2017 14:12:33)

Post-sync means after having already synced.

Wallet-A: 0.51999 PPC
Wallet-B: xxxx.000 PPC

Wallet-A is currently in your peercoin directory.
You start the v0.6 client and sync with the network.
Balance shows 0.51999 PPC
You close the client, move Wallet-B into your peercoin directory, and still see 0.51999 PPC balance.
You’re confused because you just moved Wallet-B into the directory and the balance is not 0.51999 PPC.

The issue might be that you didn’t sync with the network while Wallet-B was in your directory but rather while Wallet-A was in your directory.

You can perform a -rescan so that the balance correctly reflects the balance of the addresses held in Wallet-B.

1 Like

ok, I try again, take my oldes wallet I have (May 12 2016 15:53:55), put it in directory and start again
peercoin-qt -rescan

(if I look at blockexplorer one of my PPC address I see that still xxx.000 PPC are on this adress)

1 Like

Ok, great. Glad to hear that your address still contains the balance with which you are familiar. Let me know if -rescan solves this issue for you.

Can we confirm that you are performing a rescan correctly? How exactly are you trying to do it? I believe you said you are on Ubuntu.

1 Like

I do
./peercoin-qt -rescan
Ubuntu 17.04

there are very much (the latest) not accepted (?)

The good news is: your coins are NOT lost!

Make sure you keep the backups of you wallet.dat safe!

Export the private keys of the addresses that contain your coins, they will make sure you can always access your coins.
In the debug window do: dumpprivkey <address>
Keep those keys somewhere safe.

You can restart your client without a wallet.dat in your datadir so it’ll create a new one. Then you can import the private keys you just exported in the debug window: importprivkey <priv_key>

Or you can wait for v0.6.1 to be released soon as it’ll have an extra wallet recovery function zapwallettxes which might correctly restore your wallet without having to reimport your keys.


That is the way my wallet currently looks. All the mint by stakes say N/A where the address should be, already reported it on Github.

thx, have tried but
Linux wallet has no ‘console’ or ‘debug’ window

(./peercoind dumpprivkey -> error: couldn’t connect to server)

hope v0.6.1 will do it :slight_smile:

Oh it certainly does have an rpc interface.

Make sure you have an rpcuser and rpcpassword configured in ~/.peercoin/peercoin.conf
It should have told you to do so on first startup.


ok thx, now I have the priv. keys :slight_smile:


Great! You’re coins on those keys are now 100% in your hands!

BTW take a look at the troubleshooting here:

hurray the wallet is no more empty :slight_smile:
thx :slight_smile: