No rewards in almost 3 years, since switching to container

I started using Peercoin in 2017. I run a client continuously and I keep the wallet unlocked for minting. I used to get “mint by stake” rewards every 1 to 6 months. Since late 2019 I haven’t received any. Does that sound right?

Sometime in 2018 I switched from the peercoin Qt client on my desktop to a Docker container on a server. Could that have something to do with it? I do still unlock the wallet for minting by running peercoin-cli -rpcconnect=REDACTED1 -rpcuser=REDACTED2 -rpcpassword=REDACTED3 walletpassphrase REDACTED4 9999999 true

I do see two “generated but not accepted” mint by stake transactions in 2020. I found related topics here in the forums and most of the advice seems to be “just wait, keep on minting”. I’ll do that, but is there anything else I should try?

I’m running a container with the latest peercoin/peercoind image from Docker hub. Looks like Peercoin version v0.11.7.0-g00e2313e098731a6d32742ac9cd74f8e2ca8261b Tardigrade (release build) right now.

When I run getwalletinfo with the CLI program it returns:

  "walletname": "", 
  "walletversion": 60000,
  "balance": 42.733745,
  "unconfirmed_balance": 0.000000,
  "immature_balance": 0.000000,
  "txcount": 8,
  "keypoololdest": 1514449196,
  "keypoolsize": 1000,
  "unlocked_until": 1668617345,
  "unlocked_minting_only": true,
  "private_keys_enabled": true,
  "avoid_reuse": false,
  "scanning": false

Let me know if there’s any other debugging information that would be helpful for me to share.

See also: missing 0.11.8 image on Docker Hub · Issue #1 · peercoin/docker-peercoind · GitHub

You simply have too few coins and PoS difficulty is much higher than in 2018/2019.

1 Like