Missing link to Client


#1

I was surprised a few minutes ago to find that my Peercoin client is not pinned to my toolbar in the usual way. I am certain it was the last time I used it - it must have been.

I have gone to “All programs” and searched for “peer” and “ppc”, but it only brings me Peerunity.

I have gone to my User/AppData/Roaming folder, and the Peercoin folder is still there with wallet.dat, etc.

In case it is relevant, I have also gone to the Program Files folder and it shows the Peercoin folder. It says in the Date Modified column “20/01/2018 22:07”, which surprises me, as I did not enter this folder on Saturday, or do anything with it or the client.

But where is my client link, any ideas - how can I open it?


#2

if you go to the program directory you should find the exe of the client, you can run that
C:\Program Files (x86)\Peercoin

the startmenu link should be in
C:\Users\username\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Peercoin

idk why it suddenly got unpinned


#3

I went to the first option and found in the folder peercoind.exe - the date modified indicated June 2013! So, clearly an old client. And it did not work

I went to the second option (startmenu) and found the folder - but the only item inside was an uninstall shortcut

Any other suggestions? Otherwise, I guess I need to re-download the client …


#4

I have run a search on “Peercoin” on the whole of the C Drive and found a folder of exe files, including peercoind.exe, dated December 2017 - that’s the one

However, when I run it, it says the code execution cannot proceed, as a certain .dll file cannot be found. It says reinstall, so I will try that

UPDATE

I tried to reinstall (using the newly discovered setup.exe), but it conflicts with anti-virus.

I have downloaded a fresh Peercoin v0.6.1-win-zip from the website, and clicked on the 64 folder to extract the files. When I do this, however, it gives me an empty 32 folder.


#5

Sounds like the anti-virus program is causing you these issues. If you only use that computer to run a node you can just deactivate it.


#6

I’m going to try and create an exception for Peercoin in the virus software

But if that does not work, is it easy to deactivate a node?


#7

I was talking about deactivating the virus software.


#8

Oh, I see! No, I use the computer for everything. Why are you piloting a helicopter?


#9

I’m not. Just filling fuel.


#10

peercoin-qt.exe is the exe you are looking for, the peercoind is the commandline version or “daemon”, there is an issue with some libraries missing, but the qt should work


#11

I downloaded peercoin-qt.exe.

I unticked the open-client-automatically box, so I could at least see the peercoin-qt.exe file in the C:\Program Files (x86)\Peercoin folder before doing anything

I right clicked and opened, and it said “Insufficient system resources to complete the requested service”. The anti-virus software then kicked in and peercoin-qt.exe disappeared from the Program Files (x86)\Peercoin folder

I created an exception in the McAfee anti-virus, and peercoin-qt.exe re-appeared

I right clicked and opened - and again got the “Insufficient system resources to complete the requested service” message - and the anti-virus software again removed the .exe file!

So, I am scuppered at the moment. Let’s deal with the “Insufficient system resources” problem first - any ideas?

The computer has only been on half-an-hour, so it is not as if I have been using it all day.

UPDATE: I have switched the anti-virus scan off (for a 15 minute period) and the client opened with no problem - so I guess the “insufficient resources” is not a separate problem - it is related to the anti-virus software

ANOTHER UPDATE: After the 15-minute period elapsed, the anti-virus software came back - the client remained onscreen. I closed the client and relaunched it - the anti-virus software again kicked in

I don’t this this problem can be fully resolved at the moment - but I can use the client if I need to by switching off the anti-virus scanning.

Thanks for the help and suggestions


#12

maybe you can mark the file as exception in your antivirus software?
to make sure you have the right file you can check the SHA256 hash, it should be:

Peercoin_v0.6.1_osx.zip 	5ac49505633a64da0957f9615392afa1597d9d9f80609c0ffc3fbdf02f9565f1
Peercoin_v0.6.1_linux.zip 	c3e42572a1e62d7625051ddc75aea48171dba96d7a0c16a9fccdcd02ed8d8fa8```

you can do this from a commandline `certUtil -hashfile pathToFileToCheck [HashAlgorithm]` 

hash algo is SHA25