Lockunspent error: Invalid parameter, expected unspent output

I’m trying to unlock some outs after my rawtransaction, but I got this error:
Invalid parameter, expected unspent output

I’ve tryed from RPC and from CLI, the same script that works fine on Bitcoin and Litecoin, on Peercoin it doesn’t work…
At the moment the only solution that works is to turn off the daemon and restart…some idea?

edit: Peercoin Daemon version v0.9.0ppc Strider

root@server:/bin# ./peercoin-cli -datadir=/.ppcoin -conf=/.ppcoin/ppcoin.conf listlockunspent
“txid”: “358829b2c176240d94badd52e6b475b3f637cc6f17c1b40c7e73b53c58775006”,
“vout”: 29
“txid”: “b807458a870ccf8de43f77237a7760eea64611855bd18ea4a2a42121afa4b306”,
“vout”: 48
“txid”: “b807458a870ccf8de43f77237a7760eea64611855bd18ea4a2a42121afa4b306”,
“vout”: 59
root@server:/bin# ./peercoin-cli -datadir=/.ppcoin -conf=/.ppcoin/ppcoin.conf lockunspent true “[{“txid”:“358829b2c176240d94badd52e6b475b3f637cc6f17c1b40c7e73b53c58775006”,“vout”:29}]”
error code: -8
error message:
Invalid parameter, expected unspent output

So… I must assume that no one using rawtransaction anymore to construct payment with peercoin?

Don’t assume anything, rather invest time in making a proper bug report. If this is a bug report, I don’t know it’s not really understandable.

Also don’t run it as root.

thank you for your reply, usually I interact with the daemon via rpc, so it doesn’t matter if i ran as root for this exhibit

however, the problem is simple, in order to make a raw transaction I need to lock some unspent amount, so I use listunspent, select some transaction, than lock them and exec createrawtransaction.
So the wallet give me an hex in return that need to be signed with signrawtransaction and than finally I can send the transaction with sendrawtransaction

After that procedure I have to unlock the used transaction in order make a new raw transaction, so I
execute the command “listlockunspent” to see the json showed in my first post:

In this case I used 3 inputs to send my raw, so to clean usually I have to exec lockunspent true with the correct parameter for every locked transaction, it still works perfectly on other cryptocurrencies, with peercoin I got this error:

at the moment the only way i managed to solve it is to restart the wallet at each raw transaction to clean the locked

try escaping quotes, ie:

lockunspent true "[{\"txid\":\"358829b2c176240d94badd52e6b475b3f637cc6f17c1b40c7e73b53c58775006\", \"vout\":29}]"

anyway, it works for me, just tried locking and unlocking

thanks backpacker for your reply,

however I’ve already tried with escaping quotes, if I simply lock and unlock it works fine also for me (with or without escaping)…

this problem happen only after a successfull sendrawtransaction, so I can’t proceed to another rawtransaction without shutting down the wallet

first of all, i don’t think you need to lock unspents in order to create raw transaction, you can omit the whole lock/unlock part and just create transactions as you want.

if you have already spent previously locked output, it’s not surprise your wallet does not let you lock/unlock it again.