How to: Peerbox Support Thread (Updated to v0.6.1)


#81

peerbox-0.6.4-6 was released.
Changes are just with package dependencies, it now depends on rng-tools which make use of raspberries integrated hardware number generator.


#82

Still limited to only 8 connections and I’m stumped.
My original Peerbox install easily connected to port 9901 with more than 8 connections. Unfortunately after a firmware update my router got bricked and had to be replaced; the new router has reduced features. Notably ‘Virtual Server’ is absent, so I setup the 9901 port using ‘Port Forwarding’.
All sorts of difficulty ensued, but finally 9901 now shows as open on my WAN IP address. Port 9901 does not show up on my local IP address. I have set ‘Application Rules’ and ‘Firewall Rules’ to no avail. In Raspian ‘dhcpcd.conf’ I set up a static local IP address, as suggested in my router’s manual.
interface eth0
static ip_address=‘local addr /24’
static routers=‘router IP’
static domain_name_servers=‘DNS server’
Online port forwarding testers can see 9901 on my WAN IP, but not my local IP.
Router tech support suggested the software was not picking up the port. I see the Foreign Addr 9901 port connections through netstat, my Local Addr connection appear to go through various ports in the 4800-5800 range.
I did see this: 1) If you did not get more than 8 connections automatically, that means that you should open port 9901 at your router. The procedure is the same for Tor end regular mode.

  • but don’t understand how to follow that procedure
    Any ideas, comments?

#83

it should work with portforwarding if you have it set up correctly imo [quote=“derelle, post:82, topic:3827”]
Port 9901 does not show up on my local IP address.
[/quote]

maybe you have confused this? Or is what you call your local IP address the IP address of the peerbox?

I assume your local IP is different from the peerbox, but maybe I’m wrong about that, when you manage things from a different computer, the only computer that needs the port forwarded to is peerbox. So, if you have set up port forwarding so that it forwards port 9901 to the IP of your peerbox it should work, but maybe you already done this, than something else may be causing this from not working.

does your router support and has uPNP enabled? With upnp it should work (without port forwarding), if you try with port forwarding, maybe try turning off uPNP,
that is all I can think of right now, I hope you can get it working


#84

My peerbox RPi’s local static IP was accepted by the router & is on it’s reserved list, identitied by its IP + MAC address. Any customized router configurations related to the static IP are specifically identified with that static IP on the local network - should be good. Admittedly the router does treat static IP’s a little differently, in that they do not show up in the router generated DHCP Client List. The router is using a Dynamic IP (DHCP) Internet Setup; oddly other than this port issue, I’ve never had any connection issues.

UPnP was enabled, now disabled - no apparent effect; had tested that previously. ‘Avoid Arp Attack’ disable & enable tested - no apparent effect.

I’ve done quite of network tweaking over the past few days. Even though it appears to function perfectly, would anyone think it would help to remove & reinstall peerbox? I’m also wondering about VNC.


#85

I dont think reinstalling will be the solution, you could try to disable port forwarding and enable uPNP, and see if that works after a while, I am out of clues at the moment


#86

Thanks, I’ve gone back to a dynamic IP, UPnP is enabled.


#87

Making some progress towards setting up the node. Removed the router and with direct access to the ISP, am getting over 8 connections. I guess I know where he problem lies.


#88

maybe try to get port forwarding functional for some service and when you know how that works (with the router) you should be able to replicate it for peerbox


#89

Thanks irritant,
Got my hands on a DIR-655 router & with its feature set, was quickly able set things right by activating the Virtual Server option. Still no idea what the problem was with the DIR-605L router. Dunno - perhaps faulty? In any case it’s all good, I’m now running a raspberry pi node.


#90

Hey,

I’ve sent some coins about 1 hour ago to my wallet address I got from “peerbox -addr”.
Unfortunately I didn’t receive them yet.

If I use “peercoin -health” then I get the following answer:

"Checking if we are on the right chain…
Using peercoin.mintr.org as reference.

merkle_root_matches: False
block_count_matches: False
block_hash_matches: False
previous_block_hash_matches: False"

Could that be the reason for my problem?

I also don’t get it why I can’t update to the 0.6.4 version. “sudo apt-get update peerbox” tells me that the current version (0.5.4) is already the newest.

It would be nice if anyone could help me out.

Cheers


#91

could it be that your peerbox still needs to sync?
and maybe you can try sudo apt-get install peerbox? (instead of update)
my peerbox i checked is on 0.6.4, health also seems fine here

peerbox -health

Checking if we are on the right chain…
Using peercoin.mintr.org as reference.

merkle_root_matches: True
block_count_matches: True
block_hash_matches: True
previous_block_hash_matches: True


#92

That could be the reason. I just got it online about 13 hours ago and already restarted it a few times. Maybe I’ll just have to be more patient. :slight_smile:
I’ve tried “sudo apt-get install peerbox” but it also tells me that there’s no newer version.
My coins would just hang out on the blockchain until then right?


#93

yes you have to wait until you received the block with the transaction in it, that is probably why you dont see the coins in your wallet, and also why -health says the previous block hash doesn’t match

"blocks": 286920,

is the latest block at time of writing


#94

That makes a lot of sense.
Thanks for your help!


#95

Now my node is running since 8 hours and “peerbox -info” shows me since the first 10 minutes “blocks”: 47123. Is it normal that it’s stuck for a few hours?


#96

not exactly normal, is the disk maybe corrupted or full?
I would suggest deleting the blockchain and trying again, and if that doesn’t help get a fresh SD card. Back up your wallet.dat first of course.


#97

I still have about 9gb on my sd so that shouldn’t be the problem.
How can I delete the blockchain on raspbian?


#98

make sure you have backed up your wallet.dat first

you can find the blockchain by going to .ppcoin/ , there is also wallet.dat, so if you delete all those files (also in /database) except wallet.dat , and maybe ppcoin.conf it should redownload the blockchain correctly

The rm command removes files. Be careful with this command — rm doesn’t ask you for confirmation.


#99

Thank you! I just did it like you said and restarted peerbox afterwards. I’ll let you know tomorrow morning if it solved the problem.


#100

did you have luck with getting it to work?