Disappearing client

I have v0.10.01 downloaded. Yesterday, the shortcut on my menu bar did not work. It said:

"The item peercoin-qt.exe that this shortcut refers to has been changed or moved [etc.]

I went to the executable file in Program files, and tried to open peercoin-wallet.exe - however, I just briefly got a small black screen, like a command prompt, which instantly disappeared. The client did not open or run.

I downloaded the client afresh from the website and had it open for the rest of the day - it even minted a coin.

This morning, however, the short-cut is again not working - any ideas?

I note that the error message refers to “peercoin-qt.exe”, which I think must be wrong.

I don’t think this problem relates directly to v0.10.01, as I was running it last week, as normal.

you have viruses

Assuming you are in windows from the .exe, when you click properties, where does the path lead?

Does the below image help answer?

I also have downloaded software in Users>App Data>Roaming>Peercoin

Nowhere do I have the “Peercoin (64-bit)” with the leaf logo, as in your screenshot. I used to, but that has disappeared as well.

image

did you install it using the installer, or replace the files?

fyi the peercoin-qt.exe is in program files\peercoin\peercoin-qt.exe, not in the \daemon directory, maybe this has changed since previous version, and the shortcut is pointing to a wrong location?

I installed the client by downloading it from the website wallet page.

The short-cut was created as part of the installation. In any event, the short-cut was working last week, so I don’t think it was an old one, pointing to the wrong location.

If I go to the directory address that you mention, I get the following. It does not show a peercoin-qt.exe, and nothing shows up when I search the C: directory.

image

do you have some kind of anti virus software installed that might have removed it?
can you try reinstalling peercoin and see if the qt.exe appears?

1 Like

I have had historic problems with anti-virus, in 2018 and 2019. Creating peercoin-qt.exe as an exception to the virus scan did not work, but the problem resolved itself anyway when a new version of the client was released:

image

image

More relevantly to the present problem, the most recent quarantined entries are below, and show that something has been blocked in the past couple of days, which co-incides with the two times my short-cut stopped working:

image

I’ll re-download the client and see if I can get peercoin-qt.exe added to the virus exceptions.

Where should wallet.dat be? In the past, I’ve found it quite easily, but now I can only find a copy in the download folder:

image

The wallet-dat shown above is 16kb - presumably that is an empty version? If so, where is my loaded wallet.dat? It does not show up anywhere on the C Drive. Any idea as to what might have happened - could it have been grabbed by the anti-virus?

My last wallet.dat back-up (which sits safely on a USB stick) was a couple days ago.

in the datadir, its default location is in %APPDATA\Peercoin\

Is this the location you’re referring to? This is where I think I usually find wallet.dat, but it’s not there.

image

when you right click → properties on the short cut what does it say?
you can specify the location of the datadir with -datadir=X:\your\wallet\folder\ but it looks like it did store the blockchain in there … so idk why wallet.dat is gone
does debug.log say anything?

I restored the most recent quarantined file, and wallet.dat re-appeared in the directory previously mentioned, so it’s definitely the anti-virus (McAfee).

Also, peercoin-qt.exe re-appeared in the other directory:

image

With reference to your above question, I’ve created a short-cut, and the properties says:

“C:\Program Files\Peercoin\peercoin-qt.exe”

I’ve made peercoin-qt.exe an “allowed” file in the McAfee anti-virus software, I’ll know later if this works.

I’ve opened peercoin-qt.exe and it is rebuilding the blockchain.

1 Like

might be it cause from virus?

Yes, it was the McAfee anti-virus software. Creating an acception for peercoin-qt.exe worked.