V0.9.0 Update for Pi Zero W (non-Stakebox)


I downloaded package https://github.com/peercoin/peercoin/releases/download/v0.9.0ppc/stretch-peercoind_0.9.0-1_armhf.deb and installed on my Pi Zero W with command
sudo dpkg -i stretch-peercoind_0.9.0-1_armhf.deb

When starting peercoin with command
peercoind -deamon
I receive the message invalid command. I googled the error and I found that this may be a CPU/compiler related error. Is Pi Zero W not supported anymore with Version 0.9.0 or am I using the wrong package?


peercoind -daemon

:rofl: :rofl:
It was a typo, sorry. Of course the command I tried was peercoind -daemon. So it also doesn’t work with the correct command.

BTW, typing peercoind or peercoin-cli -getinfo leads to the same result

Ok I have Pi Zero around here somewhere. I’ll see what is up with it and why is it so specific.

I guess Pi Zero W is just Pi Zero with WIFI?

Yes you are right, W means WiFi


This call was removed in version 0.8. Use the appropriate fields from:

  • getblockchaininfo: blocks, difficulty, chain

  • getnetworkinfo: version, protocolversion, timeoffset, connections, proxy, relayfee, warnings

  • getwalletinfo: balance, keypoololdest, keypoolsize, paytxfee, unlocked_until, walletversion

any news regarding the Pi Zero issue?

Finally managed to find mine, installing OS on it now. Will report later.

Alright I know what to do, give me a day or two.

Both Raspbian and Debian pride themselves in suppporting the “armhf” architecture. Of course, they mean two different things !

Raspbian "armhf": ARMv6 + VFPv2
Debian "armhf": ARMv7

Of course.

Alright, it’s up.

Do this again:

wget -O - https://peercoin.github.io/deb-repo/peercoin.apt.key | sudo apt-key add -

And use the repo:

1 Like

Guess I need to update the OS to buster?

BTW, thx for your work.

Yes, always run latest OS. It’s important for security.
Updating Debian is easy.


I’m sorry – I didn’t realize until later that Stakebox was pure Debian. I ended up cross compiling a version that works for Raspbian Buster, but I had to get creative with an existing toolchain. Also had to tweak the memory a bit on the zero to make it run stably as there’s not much room to run anything else with the limited RAM. I’ll give your compilation a try and let you know…

Thanks again

The qt from the repo is up on my Pi Zero W and is fully synced and appears to be running normally. Thank you!

1 Like

Node is up and running again. Thx for your support @peerchemist