Trouble compiling windows qt using gitian - SOLVED

i’ve been exploring the wonderful world of qt creation and am having trouble creating the PPC windows qt.

am using the gitian process to create latest 0.4.0 on an install of Ubuntu 14.04

the dependencies seem to compile fine, but things fail on the gitian-win32 compile…
looks like an open ssl issue ??

build.log from when it seems to go awol.

thanks for any assistance :slight_smile:

as a matter of interest i also had to add package “psmisc” to deps-win32.yml

due to a problem with killall

just noticed its directing to openssl-1.0.1b
now to work out where it’s coming from … was it me ??

  • make -f makefile.linux-mingw -j2 DEPSDIR=/home/ubuntu/build ppcoind.exe USE_UPNP=1 DEBUGFLAGS=-frandom-seed=ppcoin
    /bin/sh …/share/ obj/build.h
    i586-mingw32msvc-g++ -c -O2 -w -Wno-invalid-offsetof -Wformat -frandom-seed=ppcoin -D_MT -DWIN32 -D_WINDOWS -DBOOST_THREAD_USE_LIB -DBOOST_SPIRIT_THREADSAFE -DSTATICLIB -DUSE_UPNP=1 -DHAVE_BUILD_INFO -I"/home/ubuntu/build/boost_1_47_0" -I"/home/ubuntu/build/db-4.8.30.NC/build_unix" -I"/home/ubuntu/build/openssl-1.0.1b/include" -I"/home/ubuntu/build" -I"/home/ubuntu/build/ppcoin/src"/obj -o obj/checkpoints.o checkpoints.cpp
    i586-mingw32msvc-g++ -c -O2 -w -Wno-invalid-offsetof -Wformat -frandom-seed=ppcoin -D_MT -DWIN32 -D_WINDOWS -DBOOST_THREAD_USE_LIB -DBOOST_SPIRIT_THREADSAFE -DSTATICLIB -DUSE_UPNP=1 -DHAVE_BUILD_INFO -I"/home/ubuntu/build/boost_1_47_0" -I"/home/ubuntu/build/db-4.8.30.NC/build_unix" -I"/home/ubuntu/build/openssl-1.0.1b/include" -I"/home/ubuntu/build" -I"/home/ubuntu/build/ppcoin/src"/obj -o obj/netbase.o netbase.cpp


There is a directory under contrib called gitan descriptors or something, in there you will start to recognized files u use to compile. Find the one u are failing on and have a look for the version openssl that is set and if it matches what you have being downloaded to ur build machine


Sent from my HTC Desire using Tapatalk 2

i’ve worked it out. was my error.
i’ve been trying compiling a few different coin clients. one wouldnt let me use HEAD (i canna remember which one, it was a week ago)

so i used what apeared to be the latest release on
–commit peercoin=v0.4.0ppc

i just used
–commit peercoin=HEAD
and it compiled fine. lol