Team Update #7: Peercoin v0.6.1 Now Released, Upgrade Today! Blockchain Redownload Required! (Instructions Inside)


It’s fine, we got it. Please run that node already :slight_smile:


Only took about 1.5 hours. I was using PeerUnity. I just downloaded the new wallet and everything synced over perfectly to the new version.


Kudos to a hard-working dev team! Great to see Peercoin is not just Sunny anymore and is an actual team!




Runs and looks great! Nice work dev team!

Although I do have to say that I too am on that waiting list for the patch. Once everything began to run I noticed the wallet was unlocked so I locked it, by that point I guess the damage was done. I’ve tried deleting everything and starting again but had no luck.

Anyways, I’ve since moved my wallet over using my backup wallet to my other computer and everything works fine. Even bought more PPC to see if it works and sure enough it did. :slight_smile:

Keep up the great work! :+1:


What damage was done?
Locking the wallet should not damage anything, you can unlock it again by calling walletpassphrase <password> <timeout>


Well, to clarify… the wallet ran at start up, so I used the tab to lock the wallet, after the blockchain synced I’d get the same error message and crash that was reported.

I didn’t try anything in terminal to see if it could be fixed. I’d thought after reading the forums I just had to wait.

Sorry for my use of words, maybe damage wasn’t the best word of choice. :grimacing:


v0.6.1 released two hours ago


@Zangy @cisco @ePPC @CryptoGames
I added some troubleshooting to the original post.
This should help you fix your issues.


v0.6.1 binary on Ubuntu 17.04 ->


EXCEPTION: St13runtime_error
CreateNewBlock() : ConnectBlock failed
peercoin in ThreadStakeMinter()

terminate called after throwing an instance of ‘std::runtime_error’
what(): CreateNewBlock() : ConnectBlock failed
Aborted (core dumped)


@ePPC thanks for reporting.

Restarting your client should just get you running again.

This issue is caused by minting a block offline and when coming back online, it fails to connect it to the new chain.
With a stable internet connection this issue should not happen.
This is a known issue scheduled to be fixed in 0.6.2.


I see there are three entries for a minting transaction in the out put of listtransactions all with the same txid and block hash. Is this intended? I like the one-entry format in v0.5 much better. Also why is the third entry having a strange address and the minting reward under “fee”:

        "address" : "1Wh4bh",
        "category" : "send",
        "amount" : 0.00000000,
        "fee" : <reward>,


There is an open issue for this in the github repo.




According to issue #185 that Willy is referencing is that it is not a protocol issue, it’s a display issue when using the “getrawtransaction” or “listtransactions” command. It’s is a trivial fix where the same defective code was in Bitcoin core, discovered in 2012, and fixed in 2016… you can safely disregard it… (to read more indepth like I did, go here) it will be fixed soon.

(Here’s where the same thing was broken in Bitcoin too… at this link)


Upgrade to version v0.6.1ppc-dirty on my mac went smooth, and all my peercoin has been accounted for. Great work @Peercoin Dev team!


I’m having trouble updating from peerunity.

I’ve backed up my wallet and downloaded the client.

However, the client continues to crash right after opening the app with an error message “failed to read block”

the debug log shows this

******* exception encountered *******
0 Peercoin-Qt 0x000000010951e1ca _Z13LogStackTracev + 74
1 Peercoin-Qt 0x000000010958a601 _ZN9CAutoFile8setstateEsPKc + 65
2 Peercoin-Qt 0x000000010958a4fa _ZN9CAutoFile4readEPcm + 106
3 Peercoin-Qt 0x00000001095a2188 ZN9CAutoFilersI6CBlockEERS_RT + 72
4 Peercoin-Qt 0x000000010957594f _ZN6CBlock12ReadFromDiskERK13CDiskBlockPos + 223
5 Peercoin-Qt 0x0000000109547aa1 _ZN6CBlock12ReadFromDiskEPK11CBlockIndex + 81
6 Peercoin-Qt 0x0000000109550544 _Z12SetBestChainR16CValidationStateP11CBlockIndex + 3748
7 Peercoin-Qt 0x000000010954e8a7 _Z16ConnectBestBlockR16CValidationState + 1015
8 Peercoin-Qt 0x00000001095b9b48 _Z8AppInit2RN5boost12thread_groupE + 32472
9 Peercoin-Qt 0x00000001094a5ed9 main + 4073
10 Peercoin-Qt 0x00000001094a46b4 start + 52
11 ??? 0x0000000000000002 0x0 + 2
2017-12-21 17:56:41 ERROR: bool CBlock::ReadFromDisk(const CDiskBlockPos &)() : deserialize or I/O error
2017-12-21 17:56:41 *** Failed to read block

Please help, I’m not an expert by any means. I’m on mac Siera 10.12.6


did you re-download the blockchain?


I was just able to get the blockchain download started. Thanks for your prompt response. Will post again if I run into further trouble.

removed this banner . It will no longer appear at the top of every page. #48