Problem with backup wallet

So here’s the background, I recently changed my computers operating system from Trisquel to Fedora. Before doing so I had backed up my wallet and loaded it onto my USB with all my other files. Today I re-install Peerunity and gave it a go on the new system, everything loaded, block chain is up to date, great!!

Now, as I begin to look to how I should go about loading my backup wallet I head strait to the forums because honestly, I didn’t know where to begin. So I find this post, and it lists some fairly simple steps such as…

  • Find the wallet.dat on new computer (%appdata%\PPCoin on Windows, ~./ppcoin on linux, Mac1) and delete it
  • Replace it with wallet.dat from USB

So I attempt this, but wait, I can’t seem to find the wallet.dat file!

Well, there you have it, this is my brick wall I can’t seem to overcome at the moment. May I be looking in the wrong place? Maybe, I mean, I entered ~./ppcoin on terminal, may have not been the appropriate thing to do since it didn’t find anything, I’ve looked through the /src folder but then again I may have missed it.

At this point I’m beginning to think I may have to bite the bullet on this one and accept that my coins are unrecoverable. Does anybody think otherwise?

Are there any other recommended options?

Help will be greatly appreciated, thanks!

It sounds like you’re asking to recover a file you deleted from a usb. You can try checking your trash bin. You may be up a creek, but I can give you 2 pieces of advice for the future.

  1. Always make multiple wallet backups for your cold storage, put then in multiple places. If you encrypt you should be good even in the case were someone finds a backup.
  2. When doing wallet surgery, don’t delete wallets until you’re done. Rename them instead until youve checked everything is working, then clean up after.

Thanks Nagalim, but I have the backup wallet saved, I see that on my USB named BackupWallet, but what I don’t see on the newly installed folders on the computer or my saved folders on the USB is a file named wallet.dat . I guess the question is where should I have found it to begin with?

*On second thought, I did run ~./ppcoin and remember few file addresses appear but may have clicked the wrong one which would explain why I keep seeing the response ‘no such file in directory’. I did save all the files on to my computer before, but when I save those back to the USB I still get the response ‘no such file in directory’. Yup, think I may be far up that creek right about now.

not ~./ppcoin but ~/.ppcoin

1 Like

Interesting, I enter that and I get a different response this time,

bash: /home/myusername/.ppcoin: Is a directory

Nice, so what now? How to delete and replace?

rm is for deleting files, cp for copying

1 Like

I enter:

rm ~/.ppcoin


rm: cannot remove ‘/home/myusername/.ppcoin’: Is a directory

That didn’t seem to work. :confused:

rm is for deleting files
rm filename

i dont think you should delete that directory, you just want to replace the wallet.dat that is inside that directory?

So would entering rm ~/.ppcoin/wallet.dat seem like a more appropriate approach?


1 Like

when you have copied your backupped wallet you may need to start peercoin with -rescan

1 Like

Ok, so I entered the previous command and nothing happened, terminal just dropped me to a new command line without any error message or anything.

I enter:



bash: /home/myusername/.ppcoin/wallet.dat: No such file or directory

So I guess it did its job, now then how to replace that with my backup wallet? Here is how I tried to copy my backup file and this was my response.

I enter:

cp /run/media/myusername/myUSB/Peercoin/Peerunity/BackupWallet


cp: missing destination file operand after ‘/run/media/myusername/myUSB/Peercoin/Peerunity/BackupWallet’
Try ‘cp --help’ for more information.

It looks as if my order of command wasn’t correct?

cp [options] source dest

just do cp /run/media/username/myUSB/Peercoin/Peerunity/BackupWallet ~/.ppcoin/wallet.dat

or something

1 Like

Awesome, it brought me to a new command line without indicating any errors.

So to run start Peerunity with the -rescan, would I enter something like -rescan /home/myusername/peerunity-0.2.2-linux-gitian/bin/64/peerunity ?

no at the end of that line
/home/myusername/peerunity-0.2.2-linux-gitian/bin/64/peerunity -rescan

1 Like

It worked!!!

Thank you so much irritant, you were an enormous help!

I hope this can serve as help for anybody else down the road who may encounter this situation.

Many thanks!


Hey, sorry to have to resurrect this post from the past but I’ve encountered a similar situation… this time I removed my Fedora in place for Linux Mint; much better in my opinion but back to the point.

My question is, would ~/.ppcoin still be the appropriate command to locate the wallet.dat file with the new v0.6.1?

that, or ~/.peercoin , yes

1 Like

Yes, thank you!

~/.peercoin was the working command this time around. I followed the same steps and my backup wallet was properly transfered without flaw. :grinning:

1 Like