No Balance Showing

At first my network wasn’t updating then I deleted some stuff and the app resynched which has allowed me to be connected again. The only problem is that my coins are no where to be found. The new version has a new address and I’m not sure how to gather the coins back. I tried importing the wallet.dat tied to the old address but I’ve had no luck. Any help would be greatly appreciated.

The wallet.dat file is extremely important. If you accidentally delete it and don’t have a backup saved you will permanently lose access to your coins. The Peercoin client automatically generates a new wallet.dat any time there is not one already present at launch. If you’re sure that you still have the original wallet.dat which owned a balance do the following:

[ol][li]Shutdown the client app[/li]
[li]Find the current “wallet.dat” in the Peercoin data directory and rename it something different like “wallet.empty”[/li]
[li]Copy your original “wallet.dat” into the same directory[/li]
[li]Restart the client[/li][/ol]

I did as suggested but it’s still showing 0. The new address is still there.

try runnig your client with -rescan at the operating system command line.

How do I do that[quote=“mhps, post:4, topic:2878”]try runnig your client with -rescan at the operating system command line.[/quote]

google says https://bitcointalk.org/index.php?topic=171390.0

If you can, extract your private keys, delete your wallet (after making a backup, of course), and then create a new wallet. Import your keys into a new wallet.

Another simple test is:

  1. Open up the “Debug Window”. You can access this under the “Help” menu item.
  2. Click on the “Console” tab.
  3. Type “checkwallet” (no quotes) into the input and hit ENTER. If a message other than “wallet check passed : true” comes back, you can attempt to repair your wallet.
  4. To repair the wallet, enter “repairwallet” into the input and press ENTER. This operation may take a few minutes, so be patient. Once the wallet has been repaired, you’ll get a message in the console.
  5. You can confirm that it has worked by running “checkwallet” again.