My transaction in my wallet is stuck!

Hi Every One!

I have the Peercoin Wallet v0.7.3ppc with some PPCs in it. I’m on Windows 10.

This wallet has had an ongoing problem since I installed it, it never synchronises completely. It can take many hours or a day to synchronise a few weeks or even hours, but it will always lag at least one hour on the latest blocks. And often it stays stuck, for example at 17 H late for a whole day. Today, in 8 H, it synchronised only 7 blocks. This happens although it IS synching, with usually 8 connections active with the network.

However, recently I manged to send some PPC from this wallet to an exchange site. Yesterday I tried to send more PPCs to the same site, that is more than 24 H ago, but although the wallet is now synchronised just 6 H back, the transaction still does not appear in it, and the PPC did not reach the destination web site, but the amount has been debited from my wallet already!

My wallet still says “0 confirmations”. Here is the TX status:

"État: 0/non confirmée
Date: 21/06/2019 19:40
À: PPC exodus to Litebit: 300 PX7ehPnCCQ3jzmK1ntvAcSRvRDCJNcFvRR
Débit: -400.00 PPC
Frais de transaction: -0.0023 PPC
Montant net: -400.0023 PPC
ID de la transaction: 4b57fc41d1cc0d75ae4f6bf3b7009c84341566745e060f5c7faa635f0f3e79e5"

I have restarted the wallet and the computer several times, no result. I’ve tried using 2 different WIFI. I’ve checked the transaction ID given above in the PPC blockchain explorer but it returns: “Unknown”.

The debug journal has plenty of “warning” and “error” messages but I do not understand them. So I have no idea what’s going on an what to do. I wanted to attach the content of the debug journal in a txt file but apparently I cannot attach a file to this post. I wanted to past the data at the end of this post but the data for the last 24 H fills 500+ pages in Open Office text! So I don’t know how I can share this data with you.

I of course checked all the previous posts about non wallet not synching, but the answers all say “just wait a little more”. However in this case this doesn’t help because my wallet is now synchronised well beyond the transaction point but the TX is still nowhere to be seen.

Please note also that all my previous TX still appear normally in my wallet.

(Edit: Removed “Latest development”, it has resumed synching)

I would be very grateful if one of you guys can get me out of this mess… please in simple language as I am not at all an IT expert.

Best regards,


You only have 310 PPC in that address:

You can use a Peercoin block explorer as a third party record to try to understand what’s going on. For example:
The txn you list was never broadcasted, and the address you mention has no balance (I assume it is your litebit address). You may not like this, but I suggest you do a fresh download of the blockchain. First, backup your wallet.dat file, preferably to something like a USB drive as well as to your desktop. Next, you should delete the whole peercoin data folder. If you need help finding it in %appdata%, we can help you. After you backup wallet.dat then delete the folder, start up the Peercoin app and it will recreate the folder and start the download. Once you’re all synced up, close the program and replace the new empty wallet.dat with your backup. When you restart the program, everything should be right as rain.

Let me know if you need any clarification. The most important part is that you backup your wallet.dat file before you delete anything.

1 Like

Yes indeed this confirms the 400 I’m trying to send are not in my wallet anymore but never reached destination :grimacing:

Nagalim thank you. I will do that but don’t you think at the same time I should uninstall and download again my Peercoin wallet ? It looks like it has serious defect…

You mean the wallet software? You can if you want, it can’t hurt, but I don’t think that will change much since you’re already using the latest version.

1 Like

Ok I will take care of this in the following days and reporthere on the result… Thanks a lot !
I will probably reinstall the software because it looks vey bugged.

Hi Nagalim, following your explanation, I’ve saved the wallet.dat somewhere else and also made a backup copy of the wallet.dat file that was in the folder “C:\Users\Alex\AppData\Roaming\Peerunity”. (I guess these two backups are in fact similar.)

I uninstalled my Peercoin wallet and downloaded it + installed it again.

When I opened it it showed exactly the same data than before, with zero confirmation for the txn made on June 26. The wallet is currently synchronised less than 2 days late therefore that June 26 txn should be there, but it’s not (but the 400 PPC still gone from my wallet).

So I thought I should delete the old wallet.dat file (that I copied), I did that, and now all my past txn have disappeared from my wallet, but it is till showing that is is synchronised just less than 2 days backward with almost all the blocks downloaded. So it did not download the blockchain again.

So I think I must delete more than the wallet.dat file to force my wallet to download the blockchain again from scratch. You indeed advised me: “you should delete the whole peercoin data folder” but I don’t know exactly what I must and can delete safely.

I attach a screen capture of the folders so that you can see what’s here and advice me on what to delete. The folders shown on the screen capture are located here:

The wallet.dat file you see on the capture is the new one created by the new wallet. It’s the only file I’ve deleted from my previous wallet. So I guess my old peercoin data folder is still there and I should delete it as well…

Thank you in advance for your help.
Best wishes,

Backup the wallet that contains your coins and delete the whole folder. The wallet.dat file (the old one that contains your coins) is the only file you should make sure you have kept safe. Everything else will replace itself. I suggest deleting the whole folder, because it will also rename it to ‘Peercoin’ after ‘PPCoin’ is deleted.

1 Like

Hi Nagalim, I’ve done all what you said + reinstalling a new wallet and at first the situation was exactly the same as before (txn of June 21 not executed but money gone from my wallet). So I tried some other tricks like using a much older wallet.dat and still nothing! But after a while suddenly the txn started to get confirmations. It’s now fully done. Perhaps it just needed some time (1 hour) to get fixed? So now everything is fine! :grin:
Many thanks for your kind support.
Best wishes to you,

1 Like

No problem, sorry you experienced turbulence but glad it all got worked out in the end.