[How To] Stakebox (replacement for the Peerbox)

Understood. So Raspi 2B has the same old CPU. It needs a special armv6 + VPU compilation.

Can you update to Debian Buster or you are for other reasons tied to old Stretch?
If you can update to Buster, just use the repo:

No, I don’t have anything else on the RPI, just the Peercoin client.
It’s just matter of not having enough free time to give it a look.
I will try one of these nights to give a look and upgrade, thanks

Wanted to do it asap, so I have updated to Duster following this guide:

I have removed the previous v0.9.0 and now i’ve tried to install peercoin-qt following the guide:

But this happens:


What can I do?

I’ve built new Stakebox image based on Buster with Peercoin-qt preinstalled. Let me make a clean copy and I’ll attach images here.

I did not get to test them yet, so you get to be a guinea pig. :slight_smile:

It should work fine, it’s pretty straightforward.

Is it possible to pre-activate the VNC server on it? So I won’t need to attach mouse / keyboard / monitor to my raspberry under the closet :slight_smile:

I’ll look into that.




Hostname is: “stakebox”.

Thanks, so what I need to do is this?

1- save the existing wallet.dat
2- format the SD card
3- flash the image and install stuff like in https://www.raspberrypi.org/documentation/installation/installing-images/


Ok, flashed and booted up the “normal” image.

When connecting via VNC it says:

I suppose the VNC server is not active?

Yes I think it is disabled. It should be disabled, it’s a security risk.


sudo raspi-conf

I guess manual launch is:

sudo systemctl enable vncserver-x11-serviced.service
sudo systemctl start vncserver-x11-serviced.service

Alright, i’ll have to do some more work to connect a monitor / mouse / keyboard, a job for myself of tomorrow :slight_smile:
thanks for now

Enabled VNC server, increased the swap file size (or peercoin client will crash), now it started up and looks working :slight_smile:, will check back in a few hours

Thank you for the help :+1:

How much swap does it need?

I didn’t test much, just set it to 2048MB like the other time when it worked:

Deb-repo has been updated to v0.11

I had to change the signing key again, update the key with the following command:

wget -O - https://peercoin.github.io/deb-repo/peercoin.apt.key | sudo apt-key add -

1 Like

So this time instead of the fresh install I’ll just have to update with your command + the ones on README.md of your link, and it will be ok?
I will update this weekend, thank you :slight_smile:

Yes, that’s right.

I had to use this as first command:

$ sudo apt-get --allow-releaseinfo-change update

Have a working v0.11 client, thanks :slight_smile:

Ok will include it into docs.