[How To] Stakebox (replacement for the Peerbox)

Ok perfect, thank you.

I did a tail on that file and it says:

2019-10-14 22:58:34 UpdateTip: new best=9d2546914beb6d8725e281e98eeb25601ff54bf37702a0fd08b8fd12b66cb908 height=19146 version=0x00000001 log2_trust=46.125948 moneysupply=14665608.00054845 tx=76839 date='2012-12-11 07:24:09' progress=0.046278 cache=5.3MiB(40284txo)
2019-10-14 22:58:34 ERROR: ContextualCheckBlockHeader: forked chain older than last checkpoint (height 421468)
2019-10-14 22:58:34 ERROR: AcceptBlockHeader: Consensus::ContextualCheckBlockHeader: 38b006d51caecaa37a65243fe0cbc541eefa00dbc45f048e6f5a5c51f497e7e1, bad-fork-prior-to-checkpoint (code 67)
2019-10-14 22:58:34 ERROR: invalid header received
2019-10-14 22:58:34 connect() to 91.122.151.198:9901 failed after select(): Connection refused (111)
2019-10-14 22:58:57 connect() to 91.58.136.252:9901 failed after select(): No route to host (113)
2019-10-14 22:59:26 connect() to 169.57.0.228:9901 failed after select(): Connection refused (111)
2019-10-14 22:59:43 connect() to 46.106.195.244:9901 failed after select(): Connection refused (111)
2019-10-14 22:59:44 connect() to 155.41.19.95:9901 failed after select(): Connection refused (111)
2019-10-14 22:59:50 connect() to [2003:dd:870f:ce6c:c92f:13af:2362:7808]:9901 failed: Network is unreachable (101)
2019-10-14 23:00:24 connect() to 151.62.16.66:9901 failed after select(): Connection refused (111)
2019-10-14 23:00:25 connect() to 188.238.169.61:9901 failed after select(): Connection refused (111)
2019-10-14 23:01:04 connect() to 193.117.160.194:9901 failed after select(): Connection refused (111)
2019-10-14 23:01:20 UPnP Port Mapping successful.
2019-10-14 23:01:43 connect() to 188.22.200.212:9901 failed after select(): Connection refused (111)
2019-10-14 23:01:43 connect() to 188.233.24.167:9901 failed after select(): Connection refused (111)
2019-10-14 23:01:55 connect() to 86.127.230.192:9901 failed after select(): Connection refused (111)
2019-10-14 23:02:08 ERROR: too many consecutive pos headers
2019-10-14 23:02:14 connect() to 79.219.54.39:9901 failed after select(): No route to host (113)
2019-10-14 23:02:53 connect() to [2003:de:7741:a900:8cf9:4b64:9588:cbfd]:9901 failed: Network is unreachable (101)
2019-10-14 23:03:26 connect() to 63.142.123.78:9901 failed after select(): Connection refused (111)
2019-10-14 23:03:27 connect() to [2601:1c0:5200:61:4883:ef38:3a00:ead3]:9901 failed: Network is unreachable (101)
2019-10-14 23:03:27 connect() to 78.26.151.72:9901 failed after select(): Connection refused (111)
2019-10-14 23:03:42 New outbound peer connected: version: 70001, blocks=421476, peer=36
2019-10-14 23:03:42 ERROR: CAlert::CheckSignature(): verify signature failed
2019-10-14 23:03:42 Misbehaving: 209.239.123.108:9901 peer=36 (0 -> 10)
2019-10-14 23:03:42 ERROR: CAlert::CheckSignature(): verify signature failed
2019-10-14 23:03:42 Misbehaving: 209.239.123.108:9901 peer=36 (10 -> 20)
2019-10-14 23:03:43 UpdateTip: new best=5b2f01ad1e302ddb901ea2f98a7cb997386e970d49e0195a5e56dec4ea0f7173 height=19147 version=0x00000001 log2_trust=46.126064 moneysupply=14665608.00374845 tx=76841 date='2012-12-11 07:29:08' progress=0.046279 cache=5.3MiB(40287txo)
2019-10-14 23:03:51 Error: Out of memory. Terminating.

how much memory does your system have? try enabling swap

I have a Raspberry Pi 2 model B, so it should be 1GB RAM. I followed this post instructions to set a swap file to 2048MB and restarted both pi and peercoin, will see what happens, thanks

It seems to be working as it survived the night :slight_smile:
So if anyone else has a crashing issue with the Peercoin client on Raspberry Pi 2, just add a swap partition or a swap file with a decent size and it should do the job :+1:

Thanks everyone

3 Likes

bump

Debian (Buster) repo updated, report if you find any issues.

sudo apt-get upgrade did not upgrade de wallet on the stakebox.
cant you post the deb file here again?
or give more detail how to do otherwise?

Which version of debian are you using on the stakebox? Older one, stretch (9)?

You can manually update it by downloading package from github: https://github.com/peercoin/peercoin/releases/tag/v0.9.0ppc

thx for the link.
I have manually installed the strech version without any problems.
I think the image found on https://files.peercoin.net is a stretch too

Yes but you can update running debian installation to a new version.

I am pretty confident folks who buy a stakebox just to mint their coins dont upgrade to buster unless it has an UI.

But it does have an UI :slight_smile:

I bought an new sd card and flashed raspbian Buster on it to see if it can be done without buying a stakebox
What is the simplest way to strider on it?
I cant find the FAQ how to add peercoin in the distributionlist?

3 Likes

I’m not having much luck installing on a Raspberry Pi Zero W (Buster). Is there a working build for armv6?

It seems Zero W is using 1st gen armv6 CPU. I will try to compile for that platform.

Ok compiling for Buster-armel. Will attach build here first so you can test and tell me if it works.

Debian Buster Arm v6 (armel) packages bellow, please test if you have 1st gen Raspberry Pi or Raspberry Pi Zero (W).

peercoind_0.9.0-1_armel.deb (1.4 MB) peercoin-qt_0.9.0-1_armel.deb (3.8 MB)

1 Like

Thanks for the file updates. The new packages failed to install citing unmet dependencies. For example…

“peercoin-qt:armel : Depends: libatomic1:armel (>= 4.8) but it is not installable
Depends: libboost-chrono1.67.0:armel but it is not installable
Depends: …”

I don’t have much experience with these platforms so take what I say with a grain of salt. Libboost-chrono1.67.0, for instance, is already installed on my system. It’s a Raspbian sourced build labeled as ‘armhf’ which I understand to mean ARMv6 + VFP in Raspberry Pi terms. So the dependency as installed should be compatible.

As an additional note when I originally used the Peercoin APT method everything installed normally, but binaries failed to run with an ‘illegal instruction’ error implying the executables were built for v7+.

Here are the processor ID details for my Pi Zero W:

model name : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 997.08
Features : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Thanks for your help

Just add repository to your system and install packages from there.