[How To] Stakebox (replacement for the Peerbox)

Will there be an update ob the stakebox before the hardfork date? Last time I checked there wasn’t any yet.

1 Like

Yes of course, just waited for the point releases (polish).

I followed the steps on the topped thread to update from v0.7, but was unable to compile.
Are we able to update the Peercoin wallet on the RaspberryPi right now?

I’ll write in this thread when a simple "sudo apt-get update` will do all of it. But not yet.

1 Like

Anyone care to test out v0.8.3 package on the raspberry:

peercoin-qt_0.8.3-1_armhf.deb (3.9 MB)

I needed this package so when I get some free time I’ll test this on RPI. (I need to setup a PI first)

i just ran sudo apt-get install ./peercoin-qt_0.8.3-1_armhf.deb
reboot and started peercoin
the splashscreen says it’s version v0.8.1.0-unk
so it s not 0.7 anymore…
I’ll report tomorrow or so when it has fully synced

1 Like

it has fully synced, that was quick. It seems the filters/headers in the transactions and minting tabs are empty.
clicking on them still make the tables sort, so it is just text thats empty

I went with sudo dpkg -i peercoin-qt_0.8.3-1_armhf.deb,
but I have these errors. What do to?

raspberro

Install the missing dependencies.

sudo apt install libevent-dev libprotobuf-dev

Test pls:

peercoin-qt_0.8.4-1_armhf.deb (3.9 MB)

1 Like

Just installed it
Will test
image
Syncing now:

Raspbian (stretch) .deb packages can now be found on the github/releases.

2 Likes

Success. Looks good to me.


Thanks

2 Likes

Installed raspbian-stretch-peercoin-qt_0.8.4-1_armhf.deb and it seems to be working fine for me, have synched and now processing blocks, thanks :+1:

1 Like

I have tried synching twice: first time the whole raspberry froze at 45%, I restarted it and it went back from 0.
I left it there around 24h, now I just came home and gave a look with vnc: peercoin was closed. I started it and it apparently has lost all the progress again, now I need to start from 0 :confused:
What can I do?

Is your SD card full?

I’m running my Pi in CLI mode. I downloaded and installed the raspbian-stretch-peercoind_0.8.4-1_armhf.deb package. Before the update I was running 0.7.1 and I was able to check the peercoin wallet status with command peercoind getinfo and I could also start minting.
Now this commands seems to be removed or renamed. What command shall I use now to check the system and start minting via CLI? Is it still possible?

yes use peercoin-cli for the commands, getinfo is deprecated, but peercoin-cli -getinfo should still show things

Thanks @irritant, it worked fine. Minting is now also running again with peercoin-cli walletpassphrase command. Is this command deprecated too?

As -getinfo is deprecated, is there a new parameter to get the same output? Normally deprecated calls will be removed by the time and for now it seems to be the only chance to get a short system overview. Or is there a chance to get the same information via several other calls? In this case I could create a small script to get the same output again.