How to: Peerbox Support Thread (Updated to v0.6.1)


#161

Aha, yes I should have known about that - thanks for the gentle reminder. I’ll try setting that up.
Many thanks.


#162

Not successful in running a -tor node. Peerbox seems to start off properly showing an obfuscated IP address, though never gets more than 8 connections. The -onion command always returns the same cryptic hash. After a while Peerbox switches back to my own IP address with more than 8 connections. Thus my IP is no longer obfuscated, though the -onion command still shows the same hash. I reinstalled Peerbox to see if that would help, to no avail.


#163

did you stop peerbox prior to starting it with -tor?


#164

Yes I did stop peerbox before starting with -tor.
But now get this, with peerbox running continuously for 6 days, -tor magically kicks in with a new obfuscated IP address and 20 connections. Seems to me that peerbox -tor is now working as it should, my IP address is no longer in view.
You know I very reluctantly submit queries to the support thread and now just 8 hrs after doing so, the problem self-corrects. I dunno, makes me a bit crazy.
Thanks for your attention. Cheers!


#165

Ack, peerbox -tor has flipped back to my regular IP address. Must be losing the -tor connection. Still > 8 connections.


#166

Only sometimes will Tor allow more than 8 connections. To this day I never learned what is preventing it to connect with more. On several occasions I did succeed to get more than 8 using tor.


#167

“Still > 8 connections”, by that I meant I was stilling getting more than 8 connections- sorry for my lack of clarity. Was also getting moar than 8 connects while -tor was running, before peerbox flipped back to my regular IP address.


#169

Updated to Rasbian Scratch and peerbox stopped working. Has this been tested on latest version or should I go back to jessie?


#170

I did not update it to work with new release of Debian, it’s tailored to Jessie.

I no longer have time to support and improve this project, if someone wants to take over message me.


New to Peercoin
#171

No worries, thanks mate. Jessie is still reliable and the peerbox should really be exclusively set up for the node. Will restore back to my backup image.


#172

how to update my node to the latest v0.6?


#173

I will update the repository in next few days.


#174

v0.6.1 is package is now in the repository.

To upgrade:

`sudo apt update```

sudo apt remove ppcoin

Now follow same upgrade instructions as desktop Peercoin release: https://medium.com/@PeercoinPulse/peercoin-v0-6-release-2831fb4394ad

(cleaning the old blockchain data)

reinstall:

sudo apt install peerbox

Fresh install is easy, business as usual.


I will repair bugs if there are some, but please note that this is last Peerbox update. I urge someone to take over the development, I simply no longer have spare time to do maintenance and introduce new features.


Не могу установить кошелек v0.6
#176

Curious if there’s any project updates. I’m back and considering running a PPC node again 24/7


#177

Hi!
I’m trying to install peerbox on a raspberry pi 3, but I’m getting the following errors:

The following packages have unmet dependencies:
 peerbox : Depends: ppcoin but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried installing ppcoin and get the following:

The following packages have unmet dependencies:
ppcoin : Depends: libboost-filesystem1.55.0 but it is not installable
Depends: libboost-program-options1.55.0 but it is not installable
Depends: libboost-system1.55.0 but it is not installable
Depends: libboost-thread1.55.0 but it is not installable
Depends: libssl1.0.0 (>= 1.0.1) but it is not installable
E: Unable to correct problems, you have held broken packages.

I then tried installing the various boost libraries, but they are newer versions. Would that work? I’m running a headless (ssh only) raspberry pi 3.

Uname -a reports:

Linux raspberrypi 4.9.67-v7+ #1061 SMP Tue Dec 5 17:17:24 GMT 2017 armv7l GNU/Linux

Can the lite version of raspbian work? No idea what else I can do as I’ve got those boost-dev libraries installed… Thanks!


#178

i think it is because you are running latest version of rasbian, stretch? peerbox is for jessie
https://downloads.raspberrypi.org/raspbian/images/raspbian-2017-07-05/


#179

Yes! That’s right. Do you think there will be a build for stretch?


#180

not unless someone develops it


#181

Hey,
I guess i’m having the same problem than Intensor in question comment #125.
I type > peerbox -start ::

Starting Peerbox…

After a few seconds the prompt shows up again.
Commands like -rates or -version work.

But now peerbox -info:
results either in

Peercoin deamon is still unresponsive, wait for few more seconds please.
or
Peerbox is not running. Please start Peerbox with “peerbox -start”

and after peerbox -info:
Commands -rates or -version stopped working with the line:

Peerbox is not running. Please start Peerbox with “peerbox -start”

I tried reinstalling, which doesn’t change anything.
Starting only works for user pi.

sudo systemctl start ppcoind

gives:

Failed to start ppcoind.service: Unit ppcoind.service failed to load: No such file or directory.

Getting this error i tried reinstalling peerbox, several times.

RaspberryPI 3 b
2017-07-05-raspbian-jessie

Not sure what else to try.


#182

can you look in the ~/.ppcoin directory, does debug.log give a clue?