How to: Peerbox Support Thread (Updated to v0.6.1)


#121

Can we run a full node when using Tor proxy mode? Some reason the number of connections is stuck at 8.


#122

Try restarting, it should get more than 8 connections.


#123

When i try to start Peerbox with the command peerbox -start I get this Error:

[details=Error]> Starting Peerbox…

Traceback (most recent call last):
File “/usr/bin/peerbox”, line 404, in
node = Client(testnet=False)
File “/usr/lib/python2.7/dist-packages/peercoin_rpc/peercoin_rpc.py”, line 32, in init
self.username, self.password = self.userpass() ## try to read from ~/.ppcoin
File “/usr/lib/python2.7/dist-packages/peercoin_rpc/peercoin_rpc.py”, line 52, in userpass
with open(’/home/{0}/.ppcoin/ppcoin.conf’.format(getpass.getuser()), ‘r’) as conf:
IOError: [Errno 2] No such file or directory: ‘/home/root/.ppcoin/ppcoin.conf’[/details]

The ppcoin.conf file is in /home/pi/... and not /home/root/.... Where can i change the setting that it looks in the right directory?


#124

ppcoin.conf needs to be in /home/pi/.ppcoin
Peerbox runs as pi user by default.


#125

I’m using the graphical type. When Peercoin-qt was running i couldn’t run anything in a terminal.

[details=Terminal without sudo]peerbox -start just showed Starting Peerbox...
after that the command peerbox -info (and any other command) showed
Peerbox is not running. Please start Peerbox with "peerbox -start"[/details]

It works without the Peercoin-qt now. Is there a way to start minting with it?


#126

I know it works with any pi, but which is recommended?


#127

I just realized that the autostart doesn’t work correctly. If i try : peerbox -autostart it gives me an error. What is the correct command?


#128

2 or 3 for better performance.


#129

What is the error you get?


#130

I am not able to get more then 8 connections.
I think I setup port forwarding correctly (but not sure) on my router:
I made an entry on de 'virtual server list":

  • name: ppcoin (doesn’t matter I guess?)
  • WAN port: 9901
  • LAN IP Address : my local IP adres op my Raspberry PI (192.168…etc)
  • LAN port : 9901
  • Protocol: TCP

I did a check on http://www.yougetsignal.com/tools/open-ports/
(IP adres 188.206.100.97 port 9901) but it says that the Port 9901 is closed on 188.206.100.97

But when I look in the debug.log I see succesfull connection on port 9901:

trying connection 195.154.102.171:9901 lastseen=-15.6hrs
connected 195.154.102.171:9901
Added time data, samples 11, offset -1 (+0 minutes)
nTimeOffset = +0 (+0 minutes)
Moving 195.154.102.171:9901 to tried
version message: version 60006, blocks=300760
Added 438 addresses from 195.154.102.171: 28 tried, 9687 new
Added 464 addresses from 195.154.102.171: 28 tried, 9671 new
Added 215 addresses from 195.154.102.171: 28 tried, 9651 new
received getdata for: block 20763cc2f12cc38a3697
askfor tx e2132163d2cbd7bb3b99 0
sending getdata: tx e2132163d2cbd7bb3b99

I could use some help…


#131

Sometimes some routers just wont cooperate. Keep trying though.
Unplug Raspberry, reset router then plug Raspberry back in.


#132

Hi. Need some help here. I’m using peerbox in my new raspberry. I have successfully imported the wallet, because when type “peerbox -rescan” it shows all the receiving address I have with the balances.
However, when I type in “peerbox -info”, it says 0 balance / zero balance.
What should I do in this situation?


#133

You are running it as root, do not run it as root.


#134

Do we need to open port 9050 on firewall router if running peerbox with tor? Still stuck at 8 connections, only 9901 is open. Though I can verify I can establish a network connection to the public ip + 9901 from outside the network.


#135

No, you do not have to do it. I am not sure why ppcoind sometimes can’t get more than 8 connections via Tor.


#136

I see quite a lot of the following messages in tor log, maybe there is a config that can be tweaked?

[notice] Tried for 125 seconds to get a connection to [scrubbed]:9901. Giving up.


#137

Maybe the port 9901 is being blocked by many exit nodes? Maybe we can somehow try mapping it to port 80?

[debug] circuit_remove_handled_ports(): Port 9901 is not handled.

It seems tor even recommends a reduced exit policy which blocks many ports including 9901.


#138

Certain coin is not in ppcoind, though it exists in bitcoin. Also exists in peerunity. confused as to what we should be running here?

-externalip and -bind are not in ppcoind though are in bitcoin

No ppcoind externalip and bind in codebase

Bitcoin externalip and bind


peerunity externalip and bind



#139

Help,
I cannot unlock my PPCoin Wallet in my raspberry pi 3. I installed peerbox and ran the ppcoin wallet using “sudo systemctl start ppcoin-qt@pi.service”

I am able to unlock it in my Windows PC.

I followed the “walletpassphrase password 999999999 true”, but it says that the wallet passphrase entered was incorrect.
I know my password is correct, I’ve checked it many times.

What should I do?
Btw, my password is 50 letters long. including special characters !@$, numbers, uppercase, lowercase.
What might be the problem?


#140

does it include spaces? try putting it in simple (’) and double brackets (").