Help! How to import wallet.dat to PPC wallet on Mac?

Hey guys, I’m packing a bit because I’m not having any success importing my wallet.dat file. I’m on a Mac. I’ve tried just dropping the .dat file into my library folder but when I re-start the client my balance shows zero.

I should be fine because I have multiple copies of my .dat file, but not being able to import it successfully is troubling. I know this is a noob question, but if anyone can spare the time to talk me through it I’d very much appreciate it :slight_smile:

Cheers fellow PPCers!

I have had the same problem on windows, and I wasn’t able to successfully import the wallet.dat So if anyone can respond with Mac and Windows help, it would be much appreciated from another newbie.

herb-- please describe how you attempted to import the wallet.

I encrypted and backed up the wallet.dat on the cloud from computer A with actual ppc in the wallet. I downloaded the client to computer B, and let the block chain load entirely. I downloaded the wallet.dat with the actual coins in it to the desktop of computer B. Then tried to move that file to where the wallet file was for computer B. That didn’t work, so then I tried actually just replacing the wallet file with the wallet with the coins, and that didn’t work. I kept playing around with trying to put it in different places, to the point where I think I damaged the client and it wouldn’t open any more, and so I deleted everything from computer B, and am re downloading the blockchain now after downloading another client with hopes of getting this figured out soon

Exactly to do now to get it to work is where I’m stumped. Any help is much appreciated

to further clarify, in this location
C:\Documents and Settings\personal\Application Data\PPCoin
there is a wallet.dat file

So do i just move the backup to where this is, and delete this file or leave this file and move the backup next to it?


On computer B, if you’ve already moved the wallet.dat into the PPCoin directory, I recommend you delete the block index and block database located in the same directory. What is most likely happening is that the coins you have appeared in a block that had already by synchronized with the client on Computer B, when you first set it up (but the wallet didn’t know to include them because it was working off of the default wallet.dat that was created).

As I understand it, the wallet.dat file doesn’t digitally contain the coins (those records “live” in the block chain), so what it does is provide a pointer for the client, when it synchronizes a past block, to say “Hey, that is one of mine, record it in your ledger”. If you’ve already synchronized the block chain, the client doesn’t know about those coins yet (and from what I can tell, there’s no built in process that will resynchronize the block chain when a new wallet.dat is detected).

Here is what I’d do:

  1. Keep a separate backup of your wallet.dat (that contains the record of your coins) somewhere other than the computer you want access from
  2. Shut down PPCoin-Qt, if it is currently running.
  3. In [font=courier]C:\Documents and Settings\personal\Application Data\PPCoin[/font], replace the default wallet.dat file with a copy of your backed up wallet.dat from step 1. Note: You’ve likely already done this, so if so, skip to the next step.
  4. Delete the block chain files, index and database(s), located in the same directory. For me, they all start with blk*.dat. They can be deleted without a concern because the client will rebuild them if it can’t find them.
  5. Restart PPCoin-Qt and let it synchronize with the Peercoin network again (this may take a while, depending on your internet and hard drive speeds)
  6. Profit!

[quote=“Herb, post:5, topic:1430”]to further clarify, in this location
C:\Documents and Settings\personal\Application Data\PPCoin
there is a wallet.dat file

So do i just move the backup to where this is, and delete this file or leave this file and move the backup next to it?[/quote]
Hmmm this sounds like you are doing everything correctly… i wonder if the issue is that the wallet.dat fil itself does not contain the addresses you sent to. Couple of things to check…

Ok so u load up ppcoin Qt with nothing in your Application Data\PPCoin directory… it will then create the wallet.dat file for you.

Make a note of the receive address assigned to this wallet (copy to notepad ++ or something)

now close ppcoin Qt

replace the wallet.dat file with your backup wallet.dat file

re-open ppcoin Qt and look at the receive address… has it changed??

If it has changed then the wallet.dat file is loading correctly… it does not contain the address u sent the coins to though :frowning: Have you another backup to try?? How did you create the backup?? off the Qt before or some other method like and then import the keys to the wallet? Or did you have a client wallet… backed it up at the start… then used the ppcoin Qt for lts of new addresses… format the computer and now you are trying to get back the wallet off the backup you made ages ago??

Let me know your results


I followed Ben’s steps and Fuzzybear’s advice to check the receive address. So the good news is that the block chain is reloading and that a different receive address is showing in the client. It should take an hour for me to load the entire chain, and Im hoping that the balance shows up then. Ill keep you posted.

A quick question in the meantime. Is this client the same as a bitcoin client in that a wallet backup should be good for 100 transactions going forward, or is there some other amount of transactions to note that a new backup would be needed?

Thanks for your help

Is this client the same as a bitcoin client in that a wallet backup should be good for 100 transactions going forward, or is there some other amount of transactions to note that a new backup would be needed?

That’s what I understand, too, but to be safe, after major transactions, I back up a copy of my wallet.dat and move it offline.

Well, the block chain download has completed and my coin balances still do not show up on the new client. FuzzyBear, to answer your questions, the backup is from the qt client, which I encrypted originally, backed up, did many transactions(under 100 though), and then backed it up again 1 week ago, and used that backup to load into the new client on the different computer following the steps Ben outlined.

So not sure where the problem lies, but that is the situation. This is a precautionary exercise that I’m going through, so as to gain comfort to the process, so I still have access to the original coins/client


i did however notice that both wallets were showing up, and i thought i deleted the original wallet, but i only moved it to the recycle bin, and it somehow remained, so maybe that’s the problem. im going to try the exercise again hopefully doing it right this time

I didn’t know about the 100 transactions thing.

Could someone please elaborate on that?

I thought a wallet, properly secured, was forever.

Wallet.dat files are not the the de beers of crypto??

Herb, can you confirm that the wallet.dat currently in your PPCoin directory is in-fact the copy of the exported one? With the same name, I’ve run into the situation in the past where I deleted the one I thought was the “bad” one, but instead left the default one in place. The time stamp is usually the give-away, if it looks too new.

Ben, yes I can confirm that that backup is the installed wallet as its 320kb and the standard wallet is 80kb. Absolutely sure of it. Now it wont let me open the client after switching out the wallet. I get an error message.

What error message are you seeing, and (basic troubleshooting, so I’m sure you’ve already tried, but I have to mention it anyways) have you restarted the client since you put the new wallet in?

Once we’ve got the error message, we can try a few other things.

The error message appears in a blue headline box with the caption Runaway exception and reads as follows
A fatal error has occured. Bitcoin can no longer continue safely and will quit
EXEPTION 11DbException
DB open Invaled argument
C /Program Files/PPCoin/ppcoin-qt.exe Runaway exception

lol error message now will be untrusted blockchain… delete the files and redownload the blockchain :stuck_out_tongue:

hmm yeah i have not verified if a default wallet generated has 100 addresses stored in it essentially so when you click new address you do not need to go update all your backups… i have a lot of wallet.dat files lying around and it is easy to get them mixed up… 320kb is a largeish wallet so you may have already reached the 100 as it is from the start not the last addition on that wallet… but i could be wrong here… nice all the right questions are starting to come up at least :slight_smile:

@Herb I take it nothing shows up at all? any addresses you have made? any lables on those etc? or just 1 default receive address in your 320kb wallet.dat?

you have 2 backups to work off then… you are trying the one from a week ago… or now u tried both? again any transactions showing u at all or is it possibly a corrupt wallet.dat file that is just not reading as corrupt by the client?


oh u on windows… open task manager and kill the ppcoind.exe process should fix that

Well, I think I have figured it out finally. I backed the wallet up to a thumb drive and used that to load into the new client and it worked perfectly. It appears that the few files that I had put into the cloud were put into an email service that encrypts all the files that are uploaded, and thus it must have corrupted all of the backup files somehow in the process. So I guess maybe a lesson here is to test your backup files in order to make sure they aren’t corrupted in any way.

FuzzyBear, Im sending you a few peercoins as thanks for the help. Ben, please post your address and Id like to do the same for you.

Thanks Guys!

Great news, Herb. I was worried that there was something else going on, and that a change would be needed in the steps. I’ll make a note to have people review where they are saving their backups, and to be sure they don’t run into a similar issue.

As requested, here’s my address, PNC5Qvz5QveaTPqCkDc5KpZkpd8Rq8THKc . Thank you, in advance.