Can't install Arch wallet due to failed file validity checks

#1

I’m running Arch linux, and am trying to install a peercoin wallet for the first time. I’ve tried installing both versions (Peerunity and Peercoin-QT), and installation fails for each because one of the files fails the sha256 check. When I try to install the Peerunity wallet, I get this:[code]
$ yaourt -S peerunity

==> Downloading peerunity PKGBUILD from AUR…
x .SRCINFO
x PKGBUILD
x peerunity-qt.install
x peerunity-tor@.service
x peerunity.desktop
x peerunity@.service
x peerunityd-tor@.service
x peerunityd.install
x peerunityd@.service
peerunity 0.2.2-1 (2016-05-06 11:09)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] (“A” to abort)
==> ------------------------------------
==> n

==> WARNING: This PKGBUILD describes a split package.
==> Specific package options are unknown
==> peerunity dependencies:

  • boost-libs (already installed)
  • openssl (already installed)
  • miniupnpc (already installed) [makedepend]
  • qt4 (already installed) [makedepend]
  • boost (already installed) [makedepend]
  • qrencode (already installed) [makedepend]
  • miniupnpc (already installed) [makedepend]
  • qt4 (already installed) [makedepend]

==> Continue building peerunity ? [Y/n]
==> -----------------------------------
==> Y

==> Building and installing package
==> Making package: peerunity 0.2.2-1 (Sat Jun 10 13:58:07 EDT 2017)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
-> Downloading v0.2.2.tar.gz…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 127 0 127 0 0 361 0 --:–:-- --:–:-- --:–:-- 360
100 2470k 0 2470k 0 0 1323k 0 --:–:-- 0:00:01 --:–:-- 3118k
-> Found peerunityd@.service
-> Found peerunityd-tor@.service
-> Found peerunity@.service
-> Found peerunity-tor@.service
-> Found peerunity.desktop
==> Validating source files with sha256sums…
v0.2.2.tar.gz … FAILED
peerunityd@.service … Passed
peerunityd-tor@.service … Passed
peerunity@.service … Passed
peerunity-tor@.service … Passed
peerunity.desktop … Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build peerunity.
==> Restart building peerunity ? [y/N]
==> ----------------------------------
==>
[/code]

When I try to install Peercoin-QT, I get this:[code]
$ yaourt -S peercoin-qt

==> Downloading peercoin-qt PKGBUILD from AUR…
x .SRCINFO
x PKGBUILD
x net.patch
x peercoin-qt-tor@.service
x peercoin-qt.desktop
x peercoin-qt@.service
x peercoin.install
x peercoind-tor@.service
x peercoind@.service
SonOfANoMomGoat commented on 2016-07-18 09:48
sha256sums appear to be off, I show:
sha256sums=(‘61d9de36f111c833afa491d4db2473985e126a26fd5f913db6663bdec88c1075’
‘6cb18e19847bbf4066920dbbf4371ddf07409392408fc6d079487e8759ea322e’
‘28d80670d836c57ffa38729508649afbe05338dc92c89a44c64230a7ebd97eae’
‘3f71859675561dd35c4527d96651b07996968e318dfbf26e8ce959f61a0d682f’
‘5123ec91ad8b304f46c53f49b52ffd1e41c66c3df40c23209128ce2761f7c079’
‘88459c23c17faca43582745591ebc54ed4baac85beb26aadeb3b43363c852d74’)

C5OK5Y commented on 2017-06-02 06:30
The package no longer seems to compile with GCC 7.1.1.

peercoin-qt 0.5.4-4 (2016-09-12 10:05)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] (“A” to abort)
==> ------------------------------------
==> n

==> WARNING: This PKGBUILD describes a split package.
==> Specific package options are unknown
==> peercoin dependencies:

  • boost-libs (already installed)
  • openssl (already installed) [makedepend]
  • miniupnpc (already installed) [makedepend]
  • qt4 (already installed) [makedepend]
  • boost (already installed) [makedepend]
  • miniupnpc (already installed) [makedepend]
  • openssl (already installed) [makedepend]
  • qt4 (already installed) [makedepend]

==> Continue building peercoin-qt ? [Y/n]
==> -------------------------------------
==> Y

==> Building and installing package
==> Making package: peercoin 0.5.4-4 (Sat Jun 10 14:10:58 EDT 2017)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
-> Downloading v0.5.4ppc.tar.gz…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 127 0 127 0 0 395 0 --:–:-- --:–:-- --:–:-- 396
100 128 0 128 0 0 277 0 --:–:-- --:–:-- --:–:-- 277
100 1672k 0 1672k 0 0 1008k 0 --:–:-- 0:00:01 --:–:-- 1729k
-> Found peercoin-qt.desktop
-> Found peercoin-qt@.service
-> Found peercoin-qt-tor@.service
-> Found peercoind@.service
-> Found peercoind-tor@.service
-> Found net.patch
==> Validating source files with sha256sums…
v0.5.4ppc.tar.gz … FAILED
peercoin-qt.desktop … Passed
peercoin-qt@.service … Passed
peercoin-qt-tor@.service … Passed
peercoind@.service … Passed
peercoind-tor@.service … Passed
net.patch … Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build peercoin.
==> Restart building peercoin-qt ? [y/N]
==> ------------------------------------
==>
[/code]

I suppose that I could force this to work by getting the sha256 sums of the downloaded files and then modifying the PKGBUILD to match, but that would completely undermine the purpose of the package validity check, which is an especially bad idea for software I’m going to use to manage money. Any chance the package maintainers could update the hashes in the PKGBUILDs?

#2

I’ll fix this tomorrow. Thx for the report.

#3

Having this problem as 5/15/19. Please help.
QT error.txt (2.5 KB)