[ANN] Peerbox project

#41

[quote=“mhps, post:40, topic:2485”]Thanks! I suppose I can use sftp to upload a wallet or put fund in the wallet on the pi by using importprivkey?
I could create a new address with the client on the pi and send fund to it but it costs transaction fee and destroys coin-age.[/quote]

Yes, Peerbox supports sshfs. You can move your wallet.db in root’s folder and do:

chown ppcoind:ppcoind wallet.db

This will allow ppcoind to use your wallet (permissions and all).

Now stop the ppcoind:

systemctl stop ppcoind

Move it to ppcoind directory:

mv wallet.db /var/lib/ppcoind

This will overwrite present wallet.db there.

And start ppcoind again:

systemctl start ppcoind

Now ppcoind will use your wallet.db with coins.

This should work, just try not to have your desktop client running at the same time.
And try to backup your wallet.db before trying anything.

#42

[quote=“river333, post:38, topic:2485”]I wrote a quick guide for Peerbox. @Peerchemist and others, please review this guide for mistakes and give suggestions for how to improve it.

Guide for setting up a full node on Raspberry Pi using Peerbox

Finally, set up port forwarding on your router so that your Peerbox can accept incoming connections. This allows you to distribute the Peercoin blockchain to others. Login to your router following the same steps as before. Each router is different, but you need to find the option for enabling port forwarding, and open the 9901 TCP port for Peerbox.

Within a few hours, you should have 9 or more connections on your Peerbox (indicating that you are successfully port forwarding). You can continue to check on its status whenever you want by connecting via SSH, and entering the [font=courier]peerbox-info[/font] command.[/quote]

There is also “possibility” that this will be automatic, since I’ve compiled ppcoind with miniupnpc (UPnP support). UPnP protocol enables application to request router for forwarded port, and somehow it automagically works.
Router in my flat is really really shitty (thanks, T-Com) so sometimes it works sometimes not. Mostly it works for about 2 days after I restart the router.
But general idea is that this should be plug and play if your router works properly.

Right now I have 20 connections on my laptop which IP is not set up to be forwarded in routers config, so UPnP works.

#43

[quote=“peerchemist, post:41, topic:2485”]Yes, Peerbox supports sshfs. You can move your wallet.db in root’s folder and do:

chown ppcoind:ppcoind wallet.db

You are sure it’s wallet.db not wallet.dat?

#44

[quote=“mhps, post:43, topic:2485”][quote=“peerchemist, post:41, topic:2485”]Yes, Peerbox supports sshfs. You can move your wallet.db in root’s folder and do:

chown ppcoind:ppcoind wallet.db

You are sure it’s wallet.db not wallet.dat?[/quote]

Yeah, wallet.dat. Whatever

#45

Ok I added in the things peerchemist suggested. Is that everything?

#46

Auto-start wifi on boot is probably worth adding in, yeah?

# netctl enable wlan0-your_network_name

Edit: so wifi-menu could be changed to wifi-menu -o maybe, if I understand it properly.

#47

[quote=“river333, post:46, topic:2485”]Auto-start wifi on boot is probably worth adding in, yeah?

# netctl enable wlan0-your_network_name

Edit: so wifi-menu could be changed to wifi-menu -o maybe, if I understand it properly.[/quote]

Yes, you generate template with wifi-menu -o. Save it, let’s say “homewifi” and activate it with:

netctl enable homewifi
#48

Im running Arch Arm at home as a headless server but just wondering why I couldn’t find ppcoind it in de aur repo with pacman?
I ran pacman -Syy && pacman -Ss peerc but no luck. Ill grab the files out of your repo, i just wondered if it’ll be in the ‘normal’ repo’s.

#49

[quote=“Marizele, post:48, topic:2485”]Im running Arch Arm at home as a headless server but just wondering why I couldn’t find ppcoind it in de aur repo with pacman?
I ran pacman -Syy && pacman -Ss peerc but no luck. Ill grab the files out of your repo, i just wondered if it’ll be in the ‘normal’ repo’s.[/quote]

It is not in AUR, we have our own repo with binaries.

http://peerbox.me/howto.html

So just get pacman to use our repo and install it with pacman -S ppcoind

#50

[quote=“peerchemist, post:49, topic:2485”][quote=“Marizele, post:48, topic:2485”]Im running Arch Arm at home as a headless server but just wondering why I couldn’t find ppcoind it in de aur repo with pacman?
I ran pacman -Syy && pacman -Ss peerc but no luck. Ill grab the files out of your repo, i just wondered if it’ll be in the ‘normal’ repo’s.[/quote]

It is not in AUR, we have our own repo with binaries.

http://peerbox.me/howto.html

So just get pacman to use our repo and install it with pacman -S ppcoind[/quote]

Missed the fact there was a website. Thanks for the repo! :slight_smile:

#51

@peerchemist.

There is a minor mistake in your howto;
on armv6h: sudo pacman -Syy peercoind-git
should be
on armv6h: sudo pacman -Syy ppcoind

Im sorry if this annoys you.

#52

[quote=“Marizele, post:51, topic:2485”]@peerchemist.

There is a minor mistake in your howto;
on armv6h: sudo pacman -Syy peercoind-git
should be
on armv6h: sudo pacman -Syy ppcoind

Im sorry if this annoys you.[/quote]

thx

#53

My PI has some problem of time synchronization.see the below information.

#54

PeerBox Node Info:
error: couldn’t connect to server

Raspberry Pi Info:
Hardware : BCM2708
Serial : 00000000

[root@peerbox ~]# date
Thu Jan 1 01:11:45 BST 1970
[root@peerbox ~]# hwclock
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.
[root@peerbox ~]# hwclock --debug
hwclock from util-linux 2.24.2
hwclock: cannot open /dev/rtc: No such file or directory
No usable clock interface found.
hwclock: Cannot access the Hardware Clock via any known method.
[root@peerbox ~]#

#55

[quote=“iiping, post:54, topic:2485”]PeerBox Node Info:
error: couldn’t connect to server

Raspberry Pi Info:
Hardware : BCM2708
Serial : 00000000

[root@peerbox ~]# date
Thu Jan 1 01:11:45 BST 1970
[root@peerbox ~]# hwclock
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.
[root@peerbox ~]# hwclock --debug
hwclock from util-linux 2.24.2
hwclock: cannot open /dev/rtc: No such file or directory
No usable clock interface found.
hwclock: Cannot access the Hardware Clock via any known method.
[root@peerbox ~]#[/quote]

Hi, can you reboot the device and list output of

timedatectl
#56

How to do it?
[root@peerbox ~]# timedatectl
Local time: Thu 1970-01-01 01:03:55 BST
Universal time: Thu 1970-01-01 00:03:55 UTC
RTC time: n/a
Time zone: Europe/London (BST, +0100)
NTP enabled: no
NTP synchronized: no
RTC in local TZ: no
DST active: no
Last DST change: DST ended at
Sat 1968-10-26 23:59:59 BST
Sun 1968-10-27 00:00:00 BST
Next DST change: DST ends (the clock jumps one hour backwards) at
Sun 1971-10-31 02:59:59 BST
Sun 1971-10-31 02:00:00 GMT

#57

just unplug it from power, wait 2sec and plug it again.

#58

I set the current time using date -s.but When I reboot it again to return to the initial time.

#59

Not sure how the peerbox differs from the ‘standard’ Arch ARM devices, but seeing the repo not that much. THerefor you could use ntpd. If you configure the daemon to run at boot you should be fine.
read through: https://wiki.archlinux.org/index.php/Ntpd

#60

New systemd I used should use NTP without need to install ntpd.
Now it is all about timedatactl.

However I can not reproduce this bug, and I lack rasp Pi now with me to run more tests. However I’ll see into this.